Bug Hunting Session
Bug 115289 - Crash in: connectivity::odbc::OConnection::getOdbcFunction(ODBC3SQLFunctionId)
Summary: Crash in: connectivity::odbc::OConnection::getOdbcFunction(ODBC3SQLFunctionId)
Status: RESOLVED DUPLICATE of bug 114495
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-29 04:51 UTC by rolywhittellwebb
Modified: 2018-02-05 07:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature: ["connectivity::odbc::OConnection::getOdbcFunction(ODBC3SQLFunctionId)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rolywhittellwebb 2018-01-29 04:51:47 UTC
This bug was filed from the crash reporting server and is br-11619def-bcdd-4c7e-b2d9-9f5a332e6f67.
=========================================

Using a main form with subform.  Connected to MySQL via ODBC.
All is well when main form is opened.  

Using the main record selector to advance one record crashes Base.  Every time.

I am working on a small membership database in a volunteer capacity.  I do not feel I can safely disclose the database contents as it contains a lot of personal information relating to to others.

Any suggestions would be most welcome.

Regards

Roly
Comment 1 Julien Nabet 2018-01-29 07:33:43 UTC
It could be a dup of tdf#114495

For the test, could you give a try to master daily build? (see http://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current/)
Of course, since it's a dev version, please make backup before doing any tests.

If you don't reproduce this, you'll have to wait for 5.4.5 expected at mid/end of February (see https://wiki.documentfoundation.org/ReleasePlan/5.4)
Comment 2 rolywhittellwebb 2018-02-05 00:40:33 UTC
I tried version 6.0.0.3, and all appears OK now.

Thanks for your help
Comment 3 Julien Nabet 2018-02-05 07:45:23 UTC
Thank you for your feedback!
Since there's no specific fix for this one, let's consider it like a dup of tdf#114495

*** This bug has been marked as a duplicate of bug 114495 ***