Bug 115297 - FILESAVE: PDF: Images are displayed as black boxes
Summary: FILESAVE: PDF: Images are displayed as black boxes
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All Linux (All)
: medium normal
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard: target:6.1.0 target:6.0.3
Keywords: bibisected, bisected, filter:pdf, regression
: 114874 115393 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-01-29 13:29 UTC by Xisco Faulí
Modified: 2018-03-14 10:15 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
sample document (30.21 KB, application/vnd.oasis.opendocument.text)
2018-01-29 13:29 UTC, Xisco Faulí
Details
Comparison before and after (174.65 KB, image/png)
2018-01-29 13:35 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-01-29 13:29:54 UTC
Created attachment 139433 [details]
sample document

Steps to reproduce:
1. Open the attached document. ( The document was created by exporting attachment  49277 [details] from bug 39358 to .ODT )
2. Save it as .PDF

Observed behaviour: the images in the document are displayed as black boxes. See attached image

Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 75802ae40ae67737ae9e4f1a38434e0587affff6
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2018-01-29 13:35:35 UTC
Created attachment 139434 [details]
Comparison before and after
Comment 2 Xisco Faulí 2018-01-29 13:43:37 UTC
Regression introduced by:

author	Tor Lillqvist <tml@collabora.com>	2017-11-20 14:23:17 +0200
committer	Tor Lillqvist <tml@collabora.com>	2017-11-20 16:59:02 +0100
commit	66dbd4da3afcadb1393daf9be9cecff71b86509a (patch)
tree	e5a560e6a2bfbd119c0eaaf26d356c065a82ea5a
parent	94c76b6d267ba72177e1144b408b0343d8385c37 (diff)
tdf#113918: Workaround: Load 1bpp indexed PNG as 8bpp indexed Bitmap
The alternative, to fix the X11 disaster area used by the gen, gtk,
and kde4 VCL plugins, seemed more difficult. Somebody else with more
time, feel free to revert and do that instead.

Bisected with: bibisect-linux64-6.0

Adding Cc: to Tor Lillqvist
Comment 3 V Stuart Foote 2018-01-30 05:11:20 UTC
Not reproducible on Windows builds. To PDF exports the bitmaps cleanly.
Comment 4 Buovjaga 2018-01-31 17:13:36 UTC
*** Bug 114874 has been marked as a duplicate of this bug. ***
Comment 5 Xisco Faulí 2018-02-02 09:42:17 UTC
*** Bug 115393 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2018-02-28 22:17:57 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=25cd843664919974f0d21ca7a0b02cc43e9eeabb

tdf#115297: alternative fix for displaying 1bit images

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-03-01 21:05:07 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=532cca2cedea9a9c9184685e35bdd22f0b522437&h=libreoffice-6-0

tdf#115297: alternative fix for displaying 1bit images

It will be available in 6.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-03-01 21:53:53 UTC Comment hidden (off-topic)
Comment 9 Eike Rathke 2018-03-01 22:08:16 UTC Comment hidden (off-topic)
Comment 10 Commit Notification 2018-03-14 10:15:05 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ae11dec72099fafc807d13b7169bd3177e9d539f

tdf#115297: 1bit images displaying fixed (again)

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.