Download it now!
Bug 115304 - EDITING: Calc Hide Columns, cannot Show Columns
Summary: EDITING: Calc Hide Columns, cannot Show Columns
Status: RESOLVED DUPLICATE of bug 81480
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-29 21:20 UTC by Brian Clark
Modified: 2018-01-30 12:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Clark 2018-01-29 21:20:32 UTC
Description:
Selected Columns B,C header. Right-click, selected Hide Columns. Columns B,C were no longer visible as expected. Went to bring them back by selecting Column D header, right-click, selected Show Columns. Columns B,C remained invisible. By repeatedly using Edit Undo I was able to bring them back. So I lost no work.

The online documentation for Hide Columns reads as follows:
Hides the selected column(s). To display hidden columns, right-click any column header, and then choose Show Columns.

I did discover if I dragged an adjacent column over, the hidden column would reappear, so it seems Hide Columns just makes the columns have a width of zero.

Steps to Reproduce:
1.Right-click on a column header
2.Select Hide Columns
3.Right-clock on a visible column header
4. Select Show Columns

Actual Results:  
Selected columns became hidden. Unable to make them visible again with Show Columns.

Expected Results:
All hidden columns should have reappeared


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 5.4.3.2 (x64)
Build ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU threads: 4; OS: Windows 6.1; UI render: default; 
Locale: en-CA (en_CA); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36
Comment 1 Brian Clark 2018-01-29 21:23:27 UTC
Bugzilla would not accept Version 5.4.3.2 (x64) so I had to use unspecified.
Comment 2 Telesto 2018-01-29 21:26:07 UTC
Not an expert, this seems to work:
1. Select Column A and D. 
2. Selected Show Columns.
Comment 3 m.a.riosv 2018-01-29 23:15:16 UTC
Also it possible to enter any address of the columns(s) to show in the address box (at the left of the formula bar) and use Menu/Format/Columns-Show.

For me not a bug, please if you are not agree, reopen it.
Comment 4 Regina Henschel 2018-01-29 23:40:48 UTC
It is not intuitive, that you need to select something in the hidden columns. So may be it is an enhancement request for a better UI. Because there exist already a similar enhancement request in bug 81480, closing this bug is OK. If you have a nice idea for improving the UI, add it to bug 81480.
Comment 5 Telesto 2018-01-30 12:19:27 UTC
I'm adding this as a dupe of bug 81480 instead of nota bug. It supports the enhancement request..

*** This bug has been marked as a duplicate of bug 81480 ***