Download it now!
Bug 115331 - MacOS - crash on document opening
Summary: MacOS - crash on document opening
Status: RESOLVED DUPLICATE of bug 112990
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-31 13:13 UTC by bsincick
Modified: 2018-01-31 15:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bsincick 2018-01-31 13:13:24 UTC
Description:
crash on any document opening including blank doc. Starts file recovery loop.

Steps to Reproduce:
1.open any document, either blank or pre-existing
2.document recovery starts, finishes then crashes again.
3.

Actual Results:  
gets stuck in document recovery loop.

Expected Results:
should open files normally


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_3) AppleWebKit/604.5.6 (KHTML, like Gecko) Version/11.0.3 Safari/604.5.6
Comment 1 Joe Petrus 2018-01-31 14:45:27 UTC
I am experiencing the same issue here with a freshly installed LibreOffice 6. The only thing I changed was to use OpenGL as I was hoping this would speed up the rendering of some large documents. It seems, at least for me, that this problem is related to OpenGL rendering. If I turn it off, the problem stops.
Comment 2 Xisco Faulí 2018-01-31 15:00:38 UTC
Hello,
Thanks for reporting the issue.
This is crashing because of OpenGL.
Please, disable it for the time being.
Closing as duplicate of bug 112990

*** This bug has been marked as a duplicate of bug 112990 ***