Bug 115342 - "Format -> Page -> Columns" does not register for "Undo" in icon bar
Summary: "Format -> Page -> Columns" does not register for "Undo" in icon bar
Status: RESOLVED DUPLICATE of bug 112743
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Toolbars Undo-Redo Page
  Show dependency treegraph
 
Reported: 2018-01-31 18:10 UTC by clemty
Modified: 2018-01-31 19:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Arrows point to the colums, greyed-out button, and available menu entry (95.05 KB, image/png)
2018-01-31 18:11 UTC, clemty
Details

Note You need to log in before you can comment on or make changes to this bug.
Description clemty 2018-01-31 18:10:36 UTC
Description:
On a new document, changing the page to columns as the first action via the "Format" -> "Page" dialog does leaves the "undo" icon greyed out, but shows the undo option in the "Edit" menu (undo via Ctrl-Z works too)

Version: 6.0.0.3 (x64)
Build ID: 64a0f66915f38c6217de274f0aa8e15618924765

Steps to Reproduce:
1. Open new writer document
2. Format -> Page -> Columns -> [2 columns] -> OK



Actual Results:  
"Undo" button greyed out

Expected Results:
"Undo" button not greyed out


Reproducible: Always


User Profile Reset: No



Additional Info:
Oddly enough it works if I put the "Columns" option directly in the "Format" menu


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 clemty 2018-01-31 18:11:31 UTC
Created attachment 139471 [details]
Arrows point to the colums, greyed-out button, and available menu entry
Comment 2 Dieter Praas 2018-01-31 18:40:38 UTC
I confirm it with

Version: 6.1.0.0.alpha0+ (x64)
Build ID: 77a535285f0fd5f2464430abdc67cf99be024868
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-01-23_23:04:23
Locale: de-DE (de_DE); Calc: CL

You can use Edit => Undo (2 times)

So perhaps we can treat it as a duplicate of Bug 112743?
Comment 3 Yousuf Philips (jay) (retired) 2018-01-31 19:01:05 UTC

*** This bug has been marked as a duplicate of bug 112743 ***