Download it now!
Bug 115396 - Font Carlito not recognized
Summary: Font Carlito not recognized
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: David Tardon
URL:
Whiteboard: target:6.1.0 target:6.0.4
Keywords:
: 116464 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-02 11:12 UTC by u.fuchs
Modified: 2018-04-11 11:19 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
files installed from externals' tarballs and their modes (57.68 KB, text/plain)
2018-03-29 13:17 UTC, David Tardon
Details
files with mode different from 644 (6.81 KB, text/plain)
2018-03-29 13:19 UTC, David Tardon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description u.fuchs 2018-02-02 11:12:29 UTC
LibreOffice 6.0, Version from The Document Foundation, NOT the version from the Linux distribution.

Font Carlito (substitution for MS Calibre) is installed in /opt/libreoffice6.0/share/fonts/truetype, but has insufficient rights. So this font is not recognized / can NOT be read by LibreOffice and can NOT be used.
Comment 1 Julien Nabet 2018-02-02 15:18:07 UTC
Caolán: noticing  https://cgit.freedesktop.org/libreoffice/core/commit/?id=bde5e683286096b9255254b28a862e519d57f547 thought you might be interested in this one.
When uncompressing c74b7223abe75949b4af367942d96c7a-crosextrafonts-carlito-20130920.tar.gz, I got 640 instead of 644 like other fonts. Would it be possible to put the same rights for these files in the tar.gz?
I don't have write access to server.
(btw, don't know if it would change the md5 or if this one depends only of the content of the file).
Comment 2 Caolán McNamara 2018-02-02 21:02:39 UTC
caolanm->dtardon: I guess we've no handy permission-fixer-up support for gb_ExternalPackage_add_unpacked_files or anything like that, a lot of the other fonts in my instdir/share/fonts/truetype/ are of randomy permissions, though these Carlito ones are at the broken end of the spectrum
Comment 3 David Tardon 2018-03-29 13:17:02 UTC
https://gerrit.libreoffice.org/52074 is my proposed fix. As I don't see any file that would require a mode different from 644, I just set that unconditionally. But it would be possible to add a way to change mode for some files from makefiles.
Comment 4 David Tardon 2018-03-29 13:17:59 UTC
Created attachment 140950 [details]
files installed from externals' tarballs and their modes
Comment 5 David Tardon 2018-03-29 13:19:06 UTC
Created attachment 140951 [details]
files with mode different from 644
Comment 6 Commit Notification 2018-03-30 09:22:10 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2340536cf478f95e33b718d3f69da5345fc4d2b4

tdf#115396 fix mode of files installed from externals

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-03-30 11:22:35 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4cb868abaf789afe3f2b4bc65454c21c08666a78&h=libreoffice-6-0

tdf#115396 fix mode of files installed from externals

It will be available in 6.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Buovjaga 2018-04-11 11:19:11 UTC
*** Bug 116464 has been marked as a duplicate of this bug. ***