Bug Hunting Session
Bug 115410 - Base report missing chart
Summary: Base report missing chart
Status: RESOLVED DUPLICATE of bug 117162
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chart Database-Reports-Builder
  Show dependency treegraph
 
Reported: 2018-02-02 17:02 UTC by Andrew Richardson
Modified: 2019-12-13 08:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple test case using embedded database. (13.46 KB, application/vnd.sun.xml.base)
2018-03-08 16:18 UTC, Andrew Richardson
Details
Simple test case using embedded database (for LO v6.1 and later) (12.06 KB, application/vnd.sun.xml.base)
2019-04-12 16:21 UTC, Andrew Richardson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Richardson 2018-02-02 17:02:01 UTC
Description:
I am using ReportBuilder with a bar chart in the report footer. Testing report generation within ReportBuilder is fine, chart and text is seen in output. However, when I execute the report via a Base form button, the chart is invisible (object is there but no content) yet all the text is present. I have tried relocating the chart to other report sections but same behavior. Also tried changing output format to spreadsheet, same problem.

Steps to Reproduce:
1. Use ReportBuilder to create report with bar chart
2. Save report and close
3. Generate report to ODT file, check for chart present

Actual Results:  
Object appears to be in report as outline seen when clicked, but no content (bar chart) seen

Expected Results:
Bar chart consistently seen in report.


Reproducible: Always


User Profile Reset: No



Additional Info:
See forum discussion:
https://ask.libreoffice.org/en/question/144678/base-report-missing-chart/?sort=latest


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.119 Safari/537.36
Comment 1 RolandVL 2018-02-21 18:48:09 UTC
Chart in Report of Base is also missing with Office 5.4.5.1 (x64) on Windows10
Comment 2 Buovjaga 2018-03-07 16:55:16 UTC
I see it was confirmed in Ask, but please attach an example file.
Comment 3 Andrew Richardson 2018-03-08 16:18:45 UTC
Created attachment 140480 [details]
Simple test case using embedded database.

Simple test case using embedded database [Version: 5.4.4.2 (x64)]
Edit report, see bar chart in page footer.
Execute report, note chart is not visible yet object is present if clicked in output document.
Expectation is chart will be visible regardless of section placement.
Comment 4 QA Administrators 2019-03-09 03:42:27 UTC Comment hidden (obsolete)
Comment 5 Andrew Richardson 2019-04-12 16:21:42 UTC
Created attachment 150716 [details]
Simple test case using embedded database (for LO v6.1 and later)

Recreated test case using LO 6.1.5.2
Comment 6 Andrew Richardson 2019-04-12 16:23:15 UTC
(In reply to Andrew Richardson from comment #5)
> Created attachment 150716 [details]
> Simple test case using embedded database (for LO v6.1 and later)
> 
> Recreated test case using LO 6.1.5.2

Issue still exists in LO 6.1
Comment 7 Julien Nabet 2019-12-13 08:19:41 UTC
Perhaps we may consider this one as dup of tdf#117162, even if this current one is an older bugtracker.
Comment 8 Buovjaga 2019-12-13 08:41:34 UTC
Ok let's dupe

*** This bug has been marked as a duplicate of bug 117162 ***