Bug Hunting Session
Bug 115421 - Bangla font rendering problem with letter ড় with Bangla Akademi font
Summary: Bangla font rendering problem with letter ড় with Bangla Akademi font
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2018-02-03 12:14 UTC by Kuntal Kundu
Modified: 2018-10-29 18:03 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Wrong Position (60.59 KB, image/png)
2018-02-03 12:15 UTC, Kuntal Kundu
Details
Correct Position (65.52 KB, image/png)
2018-02-03 12:16 UTC, Kuntal Kundu
Details
Bangla Akademi font (749.98 KB, application/x-font-ttf)
2018-02-03 12:32 UTC, Kuntal Kundu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kuntal Kundu 2018-02-03 12:14:16 UTC
Description:
When I type the letter ড় with Bangla Akademi font in LibreOffice Writer 6.0 or previous version, the dot sign of the letter become displaced to far right side. But the same font using in other office applications like Apache OpenOffice or WPS or MS Office the font rendered there correctly.

Actual Results:  
Need to correct the dot position exactly in below middle position.

Expected Results:
Need to correct the dot position exactly in below middle position.


Reproducible: Always


User Profile Reset: No



Additional Info:
Bangla Unicode Font


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36
Comment 1 Kuntal Kundu 2018-02-03 12:15:51 UTC
Created attachment 139549 [details]
Wrong Position
Comment 2 Kuntal Kundu 2018-02-03 12:16:25 UTC
Created attachment 139550 [details]
Correct Position
Comment 3 Kuntal Kundu 2018-02-03 12:32:06 UTC
Created attachment 139551 [details]
Bangla Akademi font
Comment 4 Khaled Hosny 2018-02-05 00:52:14 UTC
Looks like a bug in HarfBuzz (our text shaping library) or the font, I get the same result with hb-view command line tool as well as Firefox (which uses HarfBuzz as well).

Please report the issue to upstream HarfBuzz developers https://github.com/harfbuzz/harfbuzz/issues
Comment 5 Kuntal Kundu 2018-02-11 14:46:50 UTC
Sir,as per your suggestion I submitted this bug report at https://github.com/harfbuzz/harfbuzz/issues/779 please check
Comment 6 Volga 2018-04-19 16:31:43 UTC Comment hidden (obsolete)
Comment 7 Volga 2018-04-27 14:48:59 UTC Comment hidden (obsolete)
Comment 8 Volga 2018-06-06 00:52:27 UTC
HarfBuzz 1.7.7 released, so this would expected to be fixed in LibreOffice.
Comment 9 Volga 2018-06-10 08:15:38 UTC
So Khlaed, is it possible to integrate it into LibreOffice?
Comment 10 Volga 2018-07-06 14:34:05 UTC
Still reproduce in
版本:6.1.0.1 (x64)
Build ID:378e26bd4f22a135cef5fa17afd5d4171d8da21a
CPU 线程:4; 操作系统:Windows 10.0; UI 渲染:默认; 
区域语言:zh-CN (zh_CN); Calc: group threaded

So how long can you intergrate the bugfix form upstram?
Comment 11 Khaled Hosny 2018-07-06 16:40:47 UTC
(In reply to Volga from comment #9)
> So Khlaed, is it possible to integrate it into LibreOffice?

Sure, any one can send a patch to Gerrit to update the bundled version of HarfBuzz. People on Linux will get the fix once their distributions update to the fixed version of HarfBuzz.
Comment 12 Volga 2018-10-29 17:54:29 UTC Comment hidden (no-value)
Comment 13 Volga 2018-10-29 18:03:32 UTC
This is not reproducable in

版本:6.2.0.0.alpha1 (x64)
Build ID:ff46ad24d1d3cbcea45895520483ed1fd4ff488b
CPU 线程:4; 操作系统:Windows 10.0; UI 渲染:默认; VCL: win; 
区域语言:zh-CN (zh_CN); Calc: threaded

Also tested in

版本:6.1.2.1 (x64)
Build ID:65905a128db06ba48db947242809d14d3f9a93fe
CPU 线程:4; 操作系统:Windows 10.0; UI 渲染:默认; 
区域语言:zh-CN (zh_CN); Calc: group threaded