Bug 115424 - menu font missing
Summary: menu font missing
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-03 15:00 UTC by awaschb
Modified: 2018-02-27 21:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (166.73 KB, image/jpeg)
2018-02-03 15:00 UTC, awaschb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description awaschb 2018-02-03 15:00:23 UTC
Created attachment 139554 [details]
screenshot

Version: 6.0.0.0
BS: Mac OS X 10.13.3 ("High Sierra")
UI-Render: Standard

Menu font seems to be missing/corrupted.

Tried so far:

- new user account
- vanilla installation (LO)
- vanilla installation (OS & LO)

To no avail.
Comment 1 Julien Nabet 2018-02-03 15:21:59 UTC
Is it a recent pb or has it been there since the first install LO?
Did you install any specific fonts?
If yes, for the test could you disable these fonts and give a new try?
Comment 2 Alex Thurgood 2018-02-06 07:57:26 UTC
@awaschb : please tell us whether or not you have changed the system font. What you are seeing is a failed fallback representation of the font, which might indicate that the system font isn't supported.

Do you have any particular LO language packs installed ?
Comment 3 awaschb 2018-02-06 08:27:36 UTC
@alex:

Didn't change any fonts. The screenshot is taken from a "vanilla" OS install. Nothing changed apart from additionally installing LibreOffice and German language pack. No additional programs, no tinkering with system settings, so it's still default system font "San Francisco". 

The font manager shows now errors.

@Julien:

Came recently with upgrade to 5.4. But persists with 6.0. Even after OS reinstall (without any further changes to freshly installed OS).
Comment 4 Alex Thurgood 2018-02-06 12:47:49 UTC
No repro with



Version: 6.0.0.3
Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
CPU threads: 4; OS: Mac OS X 10.13.3; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group
Comment 5 Alex Thurgood 2018-02-23 08:57:04 UTC
Sorry, no repro either with:


Version: 6.0.1.1
Build-ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU-Threads: 4; BS: Mac OS X 10.13.3; UI-Render: Standard; 
Gebietsschema: de-DE (fr_FR.UTF-8); Calc: group
Comment 6 Alex Thurgood 2018-02-23 08:58:44 UTC
@awaschb : which language/keyboard combination is your OSX system set to ?
Comment 7 Telesto 2018-02-27 19:42:38 UTC
Quote from: https://ask.libreoffice.org/en/question/131310/libreoffice-54-font-gui-problem-just-rectangles-macos/

This worked:

1. Open Applications / Font Book.app
2. File -> Restore Standard Fonts
3. All non-system/default fonts will be removed and put into ~/Library/Fonts (Removed)
4. Close and reopen LibreOffice; it should work now
5. Optionally: reinstall the fonts from the removed folder and check if it still works; if not, rinse and repeat until you have identified the culprit font. In my case, I had another version of Helvetica Neue installed.
Comment 8 awaschb 2018-02-27 20:08:12 UTC
That's the fix (for my machine, that is). Still a bit strange since the test system is a vanilla MacOS installation from scratch. Did Apple b0rg fonts in 10.3.3?

Anyway: many, many thanks and all the best!
Comment 9 Julien Nabet 2018-02-27 21:01:06 UTC
Since there's no fix per se, let's put this one as WFM.