Bug Hunting Session
Bug 115539 - "Start Slideshow" does not hide notebookbar when in Outline and SlideSorter mode
Summary: "Start Slideshow" does not hide notebookbar when in Outline and SlideSorter mode
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3 all versions
Hardware: All Linux (All)
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard: target:6.1.0 target:6.0.4 target:5.4.7
Keywords:
Depends on:
Blocks: Notebookbar Slide-Show
  Show dependency treegraph
 
Reported: 2018-02-08 08:14 UTC by Ljiljan
Modified: 2018-03-21 14:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ljiljan 2018-02-08 08:14:16 UTC
Description:
"Start Slideshow" does not hide notebookbar when in Outline and SlideSorter

Steps to Reproduce:
1. Open any presentation 
2. Switch to Outline or SlideSorter mode (menu View -> Outline or View -> SlideSorter)
3. Press F5 or shift+F5 to start slideshow 

Actual Results:  
Notebookbar is not hidden

Expected Results:
Notebookbar should be hidden


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: PresentationDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.140 Safari/537.36
Comment 1 Xisco Faulí 2018-02-08 10:57:54 UTC
Confirmed in

Version: 6.1.0.0.alpha0+
Build ID: 37a2830387f437cf57104f7f509ec59944004e4d
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

Version: 5.3.0.0.alpha0+
Build ID: da01e9ec5dfb7787b4a3669486b3940590933850
CPU Threads: 4; OS Version: Linux 4.13; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

@Szymon Kłos, since you fixed bug 103355, one for you ?
Comment 2 Xisco Faulí 2018-03-14 09:22:30 UTC
Patch in gerrit: https://gerrit.libreoffice.org/#/c/51262/
Comment 3 Commit Notification 2018-03-14 16:27:59 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6a9326803c01f4c9bc7da855053ce4e80646fad8

tdf#115539, tdf#116238: Don't display the notebookbar in presentation mode

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2018-03-16 01:21:05 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f7db69e5302dca28c3cf5a36dc2328bd062fc0d9&h=libreoffice-6-0

tdf#115539, tdf#116238: Don't display the notebookbar in presentation mode

It will be available in 6.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2018-03-21 14:12:07 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2d8d36713790584b4ab7f5c94179bad05754b2ec&h=libreoffice-5-4

tdf#115539, tdf#116238: Don't display the notebookbar in presentation mode

It will be available in 5.4.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.