Bug 115643 - Problems connecting to OneDrive and Google Drive
Summary: Problems connecting to OneDrive and Google Drive
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 121688 121871 (view as bug list)
Depends on:
Blocks: Network
  Show dependency treegraph
 
Reported: 2018-02-12 09:13 UTC by Eduardo
Modified: 2018-12-12 18:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eduardo 2018-02-12 09:13:57 UTC
Description:
In ubuntu 16.04 with latest update i cant connect to One Drive ( it doesnt appear as remote service, but in windows it does). Also i cant connect to my Google Drive account....After setting the correct email and password it asks for a master password ??? Sometimes i get a general input/output error.

Think this should be solved because using the cloud is a must with the most popular cloud drives ( box, dropbox, drive and one). 

Steps to Reproduce:
1.File -> Open -> Remote file
2.Configure to use One Drive
3.It doesnt appear, so i cant set the connection.

In google drive it appears, but it doesnt work.

Actual Results:  
I cant connect to one drive or google drive

Expected Results:
Connect and work with one drive, google drive. Save, open files from cloud services.


Reproducible: Always


User Profile Reset: No



Additional Info:
Versión: 6.0.1.1
Id. de compilación: 1:6.0.1~rc1-0ubuntu0.16.04.1~lo1
Subprocs. CPU: 4; SO: Linux 4.4; Repres. IU: predet.; VCL: gtk2; 
Configuración regional: es-ES (es_ES.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 blendergeek 2018-02-13 16:34:35 UTC
In LibreOffice 6.0.1.1, there is no option for OneDrive, I can confirm that.

I can confirm the ongoing problems with Google Drive sign-in. I believe that could be a duplicate of any of the following bugs:
#101630
#100914
#97140
It could even be related to these Google Drive bugs:
#87121
#88834


However, I will point out that WebDav is working just fine. I easily connected to a NextCloud server without any problem.

I am renaming this bug from "LibreOffice doesn't work with remote files" to "Problems connecting to OneDrive and Google Drive" as that is the actual bug being reported. I am leaving as UNCONFIRMED because I am not sure what bug is being discussed here.
Comment 2 Eduardo 2018-02-19 10:11:17 UTC
So it should be a major/critical problem. Not able to use remote files nowadays is a must as more and more people rely on cloud services to save their work. In concrete One Drive is the default place to save Microsoft Office docuements.
Comment 3 Buovjaga 2018-03-07 11:17:24 UTC
Ok, Eduardo, now you have to go through these reports and determine, if you report is a duplicate:
bug 101630
bug 100914
bug 97140
bug 87121
bug 88834
Comment 4 Eduardo 2018-03-16 09:52:10 UTC
Its difficult to say. This bugs are all related to mine with different web cloud services and different Libreoffice versions. My bug is related to Gmail ( google drive WITHOUT double authentication) and One Drive. I need to say that this is a major bug as a lot of people want to use libreoffice with Drive or One, as Office does.
Comment 5 Eduardo 2018-03-19 11:12:05 UTC
As additional comments:

- In linux one drive doesnt appear in the list of avalaible services. Google drive does but it doesnt work ( IO: General Error).

In Windows 10:
- Google drive works ok.
- One Drive appears in the list. But when i paste the code in the confirmation window it says no device found and doesnt connect to one drive

Hope it can help someway...
Comment 6 Stefano 2018-06-13 15:23:42 UTC
Ubuntu 16.04 LTS
I installed a fresh LibreOffice (V6.0.4.1) today.
Trying to connect to Remote Files asks to install a 'New Service'.
Selecting 'Google Drive' opens a new windows where to input user and password.
After clicking ok, a new windows asks for a 6 digit pin 'Authentication Code'.
My phone asks me if I want to allow connection, I select 'Yes'
Using Google Authenticator on phone, I copy the Google 6 digits into the LibreOffice windows.
A new window with an Error opens: 'The specified device is invalid'
I tried this several times, both being logged into my Google A/c and unlogged.
Always got the same error.
Comment 7 Buovjaga 2018-06-13 16:08:38 UTC
It is weird that some Ubuntu users had a different problem, but now G. Drive is working fine for them: bug 117271
Comment 8 Eduardo 2018-11-24 11:15:00 UTC Comment hidden (no-value)
Comment 9 m.a.riosv 2018-12-02 23:04:17 UTC
*** Bug 121871 has been marked as a duplicate of this bug. ***
Comment 10 Xisco Faulí 2018-12-12 18:59:54 UTC
*** Bug 121688 has been marked as a duplicate of this bug. ***