Bug 115652 - Content not shown in presentation mode
Summary: Content not shown in presentation mode
Status: RESOLVED DUPLICATE of bug 115142
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-02-12 12:00 UTC by Paul Menzel
Modified: 2018-03-07 12:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Minimal example (615.50 KB, application/vnd.ms-powerpoint)
2018-02-12 12:00 UTC, Paul Menzel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Menzel 2018-02-12 12:00:25 UTC
Created attachment 139828 [details]
Minimal example

Going into presentation mode with LibreOffice 5.4 and 6.0.1.1, the content is not shown.
Comment 1 Telesto 2018-02-12 19:16:01 UTC
No repro with:
Version: 6.1.0.0.alpha0+
Build ID: 8a0b61172a14b8b766a2e85f27762db3558d3af7
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-02-06_03:28:54
Locale: nl-NL (nl_NL); Calc: CL
Comment 2 Paul Menzel 2018-02-13 09:22:27 UTC
Testing this under Ubuntu 16.04 with LibreOffice 5.1.6~rc2-0ubuntu1~xenial2, it also works fine. So, there is something different in my environment.
Comment 3 Paul Menzel 2018-02-13 09:33:25 UTC
I am also unable to reproduce it with Ubuntu 17.10 with LibreOffice package 5.4.2-0ubuntu0.17.10.1.
Comment 4 raal 2018-02-14 14:11:31 UTC
no repro Version: 6.1.0.0.alpha0+; windows

Try to reset your profile: https://wiki.documentfoundation.org/UserProfile
Comment 5 Paul Menzel 2018-02-14 14:28:07 UTC
(In reply to raal from comment #4)

[…]

> Try to reset your profile: https://wiki.documentfoundation.org/UserProfile

Thanks. I reset my profile, and it did unfortunately *not* help.
Comment 6 Buovjaga 2018-03-06 15:28:01 UTC
Please copy and paste here the contents of your Help - About. This allows us to know more about your system.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 7 Paul Menzel 2018-03-06 15:34:07 UTC
(In reply to Buovjaga from comment #6)
> Please copy and paste here the contents of your Help - About. This allows us
> to know more about your system.

Please find the output below.

> Version: 6.0.1.1
> Build ID: 00m0(Build:1)
> CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: gtk3; 
> Locale: en-US (en_US.UTF-8); Calc: group
Comment 8 Xisco Faulí 2018-03-06 16:26:50 UTC
Regression introduced by:

author	Michael Stahl <mstahl@redhat.com>	2017-11-10 23:28:19 +0100
committer	Michael Stahl <mstahl@redhat.com>	2017-11-10 23:53:15 +0100
commit	99e373cd4c78084ded349f3e3de7b0504af2dd90 (patch)
tree	0c1ff8718814ac92ee6f2f766d0c66bf94f32343
parent	3c18e816c23f1e49a44b12cf7aee10c47af7e2ec (diff)
slideshow: clip shapes in secondary screen window
When using the presenter console, the secondary screen has
a small view of the current slide.

Currently nothing clips the shapes that are on the slide,
so they may be rendered outside the slide rectangle,
because there's a single VCL-canvas and OutPutDevice that covers
the entire screen.

Set up some brute force clipping in DrawShape::getViewRenderArgs().

Bisected with: bibisect-linux64-6.0

Adding Cc: to Michael Stahl
Comment 9 Michael Stahl 2018-03-07 12:29:25 UTC
this is fixed too on master by reverting the commit in comment #8

*** This bug has been marked as a duplicate of bug 115142 ***