Download it now!
Bug 115681 - Navigate By Function: Found Object is not Displayed if Cursor is Positioned in Comment
Summary: Navigate By Function: Found Object is not Displayed if Cursor is Positioned i...
Status: RESOLVED DUPLICATE of bug 115666
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Navigate-By
  Show dependency treegraph
 
Reported: 2018-02-13 11:17 UTC by Harald Koester
Modified: 2018-03-06 15:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example file (12.17 KB, application/vnd.oasis.opendocument.text)
2018-03-06 15:05 UTC, Harald Koester
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2018-02-13 11:17:29 UTC
In order to reproduce, do:
[1] Open new text document and create 3 pages (Ctrl+Enter).
[2] In each page insert an image (Menu: Insert > Image…)
[3] Add a comment on the first page and position the cursor in the comment.
[4] Display Find toolbar and select Graphics in the “Navigate By” drop-down menu.
[5] Click the down arrow in order to find the next image on page 2. The first page is still displayed.
[6] Move to the second page with mouse wheel. The image on the second page is selected. This means, that the search has been performed correctly but the result has not been displayed at step 5. Expected: At step 5 the second page with the selected image should be displayed.

The bug also occurs if you use text frames instead of images. I did not check the other object types.
Comment 1 Buovjaga 2018-03-05 17:58:17 UTC
Repro steps 1-3 do not seem necessary to be done from scratch, so please attach an example file to speed up QA process.
Comment 2 Harald Koester 2018-03-06 15:05:28 UTC
Created attachment 140390 [details]
Example file

Just open the example file and position the cursor in the comment. Then go on with step 4.
Comment 3 Buovjaga 2018-03-06 15:14:24 UTC
(In reply to Harald Koester from comment #0)
> [5] Click the down arrow in order to find the next image on page 2. The
> first page is still displayed.

No problem here. It seems Jim's fix for bug 115666 solved this.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 13164cc99dc6184fb2c12e56e9c0dea0d5692eec
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 4th 2018

*** This bug has been marked as a duplicate of bug 115666 ***