Download it now!
Bug 115705 - When presentations are opened, LibreOffice does not respect the "Move focus to next window" in System Preferences
Summary: When presentations are opened, LibreOffice does not respect the "Move focus t...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: IA64 (Itanium) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-14 09:00 UTC by jean.christophe.helary
Modified: 2019-03-10 09:24 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jean.christophe.helary 2018-02-14 09:00:19 UTC
Description:
The shortcut set in System Preferences > Keyboard > Shortcuts > Keyboard > Move focus to next window, is not respected when the front document is a presentation. LibrOffice does not change the focus to a new document regardless of the shortcut.

Steps to Reproduce:
1. Open 2 presentation
2. Use the shortcut set in System Preferences to change the front document

Actual Results:  
The front document does not change

Expected Results:
The front document should change to the next document


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 4; OS: Mac OS X 10.13.3; UI render: default; 
Locale: en-US (en_JP.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_3) AppleWebKit/604.5.6 (KHTML, like Gecko) Version/11.0.3 Safari/604.5.6
Comment 1 Alex Thurgood 2018-02-14 09:41:31 UTC
Confirming with 

Version: 6.0.0.3
Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
Threads CPU : 4; OS : Mac OS X 10.13.3; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 2 Alex Thurgood 2018-02-14 09:49:01 UTC
OK, this is weird.

I can't reproduce this behaviour with two Impress documents and 

Version: 6.0.0.3
Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
Threads CPU : 4; OS : Mac OS X 10.13.3; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group

Let me try with the latest 6.0.1.1
Comment 3 Alex Thurgood 2018-02-14 10:38:06 UTC
OK, so further testing with

Version: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 4; OS: Mac OS X 10.13.3; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group


leads to NO REPRO for me, sorry.
Comment 4 Alex Thurgood 2018-02-14 10:39:49 UTC
I can switch between the two Impress documents with the Ctrl-F4 shortcut.
Comment 5 Alex Thurgood 2018-02-14 10:41:07 UTC
Jean-Christophe : Other people have noticed other problems with the JP langpack. If you switch back to EN or FR, do you still encounter the problem ?
Comment 6 Alex Thurgood 2018-02-14 10:41:54 UTC
See, e.g. bug 115361
Comment 7 jean.christophe.helary 2018-02-14 10:47:13 UTC
Alex,

I'm not using the JP language pack. The OS is set to English and the locale is automatically set to en_JP.UTF-8.

I just tested again with 4 documents I was working with today, I can switch document with the 2 docx files but when I switch to a pptx file I'l locked there.

My shortcut is Cmd+ESC. I checked if it was conflicting with something else but found nothing and had the same behavior after changing it to a different shortcut...
Comment 8 jean.christophe.helary 2018-02-14 11:07:07 UTC
I just tested with the lates LO5 and I can reproduce with the same set of files and with a different set including XLSX files, in which case only the PPTX files block the rotation... Weird. Honestly, I don't use LO that often (only as a backup when MSO bugs) so that's probably the reason why I did not notice that earlier...
Comment 9 Alex Thurgood 2018-02-14 15:22:29 UTC
Hmm, I still can't reproduce with the default OS shortcut on my MacbookPro (which is Ctrl-F4) and 2 PPTX files using

Version: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
Threads CPU : 8; OS : Mac OS X 10.13.3; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 10 jean.christophe.helary 2018-02-14 23:54:03 UTC
Ok, so it's likely it's something related to my machine. I'll check on a default account and eventually on a different machine and will report back. Thank you for verifying on your side.
Comment 11 Alex Thurgood 2018-02-16 07:52:37 UTC
(In reply to jean.christophe.helary from comment #10)
> Ok, so it's likely it's something related to my machine. I'll check on a
> default account and eventually on a different machine and will report back.
> Thank you for verifying on your side.

Since you mentioned that you have a JP system locale, are you also using an Apple Mac JP keyboard layout ? 

There are a few known issues about some shortcuts not working with non-QWERTY keyboards linked to the hardcoding of the ASCII-based shortcuts in LO's code.

One recent discussion focussed on the Cmd-tilde key not working correctly in a non-En/US setup (on my FR Apple keyboard this is Cmd-accent grave instead), so it may also be dependent on the type of keyboard you have.
Comment 12 jean.christophe.helary 2018-02-16 12:22:53 UTC
Alex,

It looks like something like this could be at stake.

I tried to reproduce the issue on a default account and succeeded. Then I changed the shortcut to something totally different (Cmd+Shift+@ on my JIS keyboard) and then the issue was fixed.

I could reproduce the fix on my work account.

So, yes, it looks like something is hardcoded in LO that makes it not accept at least that Cmd+ESC on my JIS keyboard but that is *only* when the starting file is a PPTX file in my case (DOCX and XSLX) worked fine.

I also reproduced that with newly created native LO documents. As soon as a presentation is involved the rotation of files is stopped.
Comment 13 Alex Thurgood 2018-03-07 07:58:58 UTC
Given the other related bugs, confirming.
Comment 14 QA Administrators 2019-03-08 03:41:15 UTC Comment hidden (obsolete)
Comment 15 jean.christophe.helary 2019-03-10 09:24:31 UTC
Version: 6.2.0.3
Build ID: 98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
CPU threads: 8; OS: Mac OS X 10.14.3; UI render: default; VCL: osx; 
Locale: en-US (en_JP.UTF-8); UI-Language: en-US
Calc: threaded