Bug 115713 - [NEWHELP] 2nd and 3rd level heading font misses international characters
Summary: [NEWHELP] 2nd and 3rd level heading font misses international characters
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All All
: medium normal
Assignee: Adolfo Jayme
URL: https://help.libreoffice.org/6.1/sl/t...
Whiteboard:
Keywords:
Depends on:
Blocks: New-Help
  Show dependency treegraph
 
Reported: 2018-02-14 11:51 UTC by Martin Srebotnjak
Modified: 2018-07-09 06:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
See a help page in Slovenian with wrong č (114.21 KB, image/png)
2018-02-14 11:52 UTC, Martin Srebotnjak
Details
Offline help is OK (67.66 KB, image/png)
2018-02-14 12:30 UTC, Martin Srebotnjak
Details
Helvetica used (30.88 KB, image/png)
2018-02-14 21:12 UTC, Martin Srebotnjak
Details
Screenshot from macOS 10.12.6 (106.18 KB, image/png)
2018-02-15 12:36 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2018-02-14 11:51:43 UTC
Description:
Letters č and Č are displayed in other font inside 2nd and 3rd level headings (bold green ones); other fonts seem OK for Slavic Latin character sets.

Steps to Reproduce:
1. Open Help in Slovenian
2.
3.

Actual Results:  
Letters č and Č are displayed in other font inside 2nd and 3rd level headings (bold green ones); other fonts seem OK for Slavic Latin character sets.

Expected Results:
Start using Unicode compliant fonts, and before using them, try them on several languages and scripts, like Slavic, Greek etc.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Martin Srebotnjak 2018-02-14 11:52:23 UTC
Created attachment 139899 [details]
See a help page in Slovenian with wrong č

See for yourself:
https://help.libreoffice.org/6.0/sl/text/swriter/01/06100000.html?DbPAR=WRITER#bm_id3149353
Comment 2 Olivier Hallot 2018-02-14 12:07:21 UTC
Help UI fonts are defined in default.css 

https://opengrok.libreoffice.org/xref/help/help3xsl/default.css

font-family: "Segoe UI", Ubuntu, Cantarell, "Noto Sans", "DejaVu Sans", "Lucida Sans Unicode", "Helvetica Neue", Helvetica, Tahoma, sans-serif;
Comment 3 Martin Srebotnjak 2018-02-14 12:15:42 UTC
The problematic font is used for h2 and h3 tags inside main window (displayed help content).
But since this appears also in the main text in bold text, like here:
https://help.libreoffice.org/6.0/sl/text/swriter/main0206.html
(see "Orodna vrstica *Označevanje in oštevilčevanje* vsebuje funkcije ...", where č in bold "Označevanje in oštevilčevanje" has the same problem) it seems the problem is all bold text in this font.
It seems bold component of the used font is not adequate for an international/l10n website and should be replaced or a better version of this font (also hosted on this side, like the issue being solved for www.libreoffice.org) should be hosted on the website itself.
Comment 4 Buovjaga 2018-02-14 12:25:40 UTC
(In reply to Olivier Hallot from comment #2)
> font-family: "Segoe UI", Ubuntu, Cantarell, "Noto Sans", "DejaVu Sans",
> "Lucida Sans Unicode", "Helvetica Neue", Helvetica, Tahoma, sans-serif;

Martin: note that we are using system fonts, not anything hosted by us or Google. The font preference is from left to right: first Segoe UI and if it is not found, try the next etc.

So please recommend the best fonts to use with Win/Mac/Linux
Comment 5 Martin Srebotnjak 2018-02-14 12:30:38 UTC
Since this is a website (this problem does not appear with offline help in 6.0), please embed font on the website, like it will be now hosted for the main site www.libreoffice.com, that we found there is the problem by linking to the Google hosted font for that site.
So then you can have any font you desire (if it also covers Unicode satisfactory).
I am attaching the offline help screenshot of the same help content, which is fine on macOS.
Comment 6 Martin Srebotnjak 2018-02-14 12:30:58 UTC
Created attachment 139904 [details]
Offline help is OK
Comment 7 Buovjaga 2018-02-14 13:42:37 UTC
Ok, we are looking into it and I hope we could in any case stick to using system fonts.

But Martin: I need some information from you. As you are using Firefox, please do the following

Open the Inspector like so: https://developer.mozilla.org/en-US/docs/Tools/Page_Inspector/How_to/Open_the_Inspector

Use the Select element tool to select any heading: https://developer.mozilla.org/en-US/docs/Tools/Page_Inspector/UI_Tour

Click in the Fonts tab in the right side of the inspector to see the actual font used in your browser: https://developer.mozilla.org/en-US/docs/Tools/Page_Inspector/How_to/View_fonts

In my case on macOS, the č looks fine and the font used is Helvetica Neue.
On Linux, I get Ubuntu font and even though the č looks fine, there is a huge number of problems with complex text. So we have to pick new fonts in any case, we just have to find good ones for Linux and Mac.
Comment 8 Buovjaga 2018-02-14 17:24:00 UTC
On my Linux system, the scripts fall back to fonts that we do not define in our CSS:
- most of the complex layout scripts fall back to FreeSerif
- Dzhongkha falls back to Noto Sans Tibetan
- Khmer falls back to Taprom
- Korean falls back to NanumGothic

I have the huge ttf-google-fonts-git package installed (just updated).

As the fallbacks fail when switching to a language with CTL script, we have to explicitly define more fonts in the CSS.
Comment 9 Martin Srebotnjak 2018-02-14 21:12:03 UTC
But Buovjaga :)
I see these two fonts in a h2 element where we have a problem with a "č":
Helvetica Neue Condensed Bold
and
Helvetica Neue Bold

If I am interpreting this well, system uses first Helvetica Neue Bold, and because "č" is not there, it fallsback to Helvetica Neue Condensed Bold?

That would explain what we can see there. The subscript in the screenshot says: "Used As: Helvetica Neue".
Comment 10 Martin Srebotnjak 2018-02-14 21:12:29 UTC
Created attachment 139914 [details]
Helvetica used
Comment 11 Buovjaga 2018-02-15 12:36:33 UTC
Created attachment 139923 [details]
Screenshot from macOS 10.12.6

For me on macOS, Helvetica Neue Bold shows it fine. Is everything OK with your Helvetica Neue? It is complete?

Can you suggest some other font we should target on macOS?

Incidentally, we are dealing with the same problem area as this discussion in the dev list: https://lists.freedesktop.org/archives/libreoffice/2018-February/079435.html

Compared to all the complex scripts, Slovenian is easy peasy. For example, Nanum Gothic is almost 3 megabytes, if we were to host it ourselves. That is only for Korean.
Comment 12 Adolfo Jayme 2018-07-09 06:25:45 UTC
I would also suggest maybe there’s a conflict with locally installed versions of Helvetica Neue, as I can’t reproduce the issue here.

I added “system-ui” to the font stack, so this should be OK now in both Blink- and WebKit-based browsers. (Firefox doesn’t yet transition from the old “-apple-system” name, but I’m reluctant to add vendor prefixes).
Comment 13 Martin Srebotnjak 2018-07-09 06:50:58 UTC
I can confirm - on my system it now works fine!
Thanks.