Download it now!
Bug 115746 - alt+f jumps between File and Form
Summary: alt+f jumps between File and Form
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.1.0 target:6.0.3
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2018-02-15 14:13 UTC by Alex ARNAUD
Modified: 2018-03-08 11:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex ARNAUD 2018-02-15 14:13:02 UTC
Description:
Since LibreOffice 6.0, on the GTK3 file, alt+f is both mapped to File and Form

Steps to Reproduce:
1. Open LibreOffice Write GTK3
2. Press alt+f
3. Press escape
4. Press alt+f

Actual Results:  
LibreOffice opens Form menu

Expected Results:
LibreOffice should opens File menu


Reproducible: Always


User Profile Reset: No



Additional Info:
It's regression that appear only on GTK3, not on GTK2 since version 6.0 because it worked on 5.4 release.

Best regards.


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Caolán McNamara 2018-03-01 15:31:21 UTC
But there are two entries with the same _F accelerator in the menu. i.e. for some reason forms is in the menubar now. Is not gtk specific that there's a collision there.
Comment 2 Commit Notification 2018-03-02 08:49:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3d39c2a84f05e4b6dcdccc7e5380a98c147ee704

Resolves: tdf#115746 alt+f used twice in the writer menubar

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Caolán McNamara 2018-03-02 08:54:06 UTC
backport for 6-0-0 in gerrit
Comment 4 Commit Notification 2018-03-07 12:18:19 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=12a80d523abfd35601bd8a111fd8c2cacdfd8b9c&h=libreoffice-6-0

Resolves: tdf#115746 alt+f used twice in the writer menubar

It will be available in 6.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Alex ARNAUD 2018-03-08 11:42:14 UTC
Hello all,

I've tested the daily build of LibreOfficeDev 6.1 GTK3 and I can confirm that it works correctly. Thanks Caolán for the fix.

Best regards.