Download it now!
Bug 115772 - The "reject track change" feature doesn't work as it should when rejecting text formatting.
Summary: The "reject track change" feature doesn't work as it should when rejecting te...
Status: RESOLVED DUPLICATE of bug 58813
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2018-02-16 07:50 UTC by badmofosteven
Modified: 2020-04-28 13:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
About LibreOffice (21.82 KB, image/png)
2019-02-17 04:51 UTC, badmofosteven
Details

Note You need to log in before you can comment on or make changes to this bug.
Description badmofosteven 2018-02-16 07:50:32 UTC
Description:
If you apply formatting to text while the record (track changes) feature is on, the formatting does not revert back if you reject the change. Instead, only the history of the change goes away. The text formatting options I've noticed this with are italics, bold, font color, and highlight, but may not be restricted to these.

Steps to Reproduce:
1.Type something in LibreOffice Writer
2.Turn the record (track changes) feature on
3.Apply formatting to that text, such as italics
4.Right-click this text and press "reject change."

Actual Results:  
The history of the change got deleted, as it should have, but the formatting of the text itself did not revert.

Expected Results:
It should have reverted the text formatting.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 1; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36
Comment 1 Mike Kaganski 2018-02-16 08:15:06 UTC
Confirmed using Version: 6.0.1.1 (x64)
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: ru-RU (ru_RU); Calc: 

and also OpenOffice.org 3.3.0
OOO330m20 (Build:9567)

The changes management dialog even doesn't offer an option to reject the change...
Comment 2 QA Administrators 2019-02-17 03:44:58 UTC Comment hidden (obsolete)
Comment 3 badmofosteven 2019-02-17 04:51:26 UTC
Created attachment 149334 [details]
About LibreOffice

The bug is still present.
Comment 4 NISZ LibreOffice Team 2020-04-28 13:18:57 UTC
Seems to be already covered by bug #58813 - when changes are tracked, the new character formatting is recorded, but if there was something non-default set that cannot be restored by rejecting the change.

*** This bug has been marked as a duplicate of bug 58813 ***