Bug 115787 - Indent in style is not taken into account with lists
Summary: Indent in style is not taken into account with lists
Status: RESOLVED DUPLICATE of bug 83532
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-16 17:43 UTC by roumanet
Modified: 2018-03-07 20:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Formating error with bullets (105.39 KB, image/png)
2018-02-16 17:43 UTC, roumanet
Details
Word comparison (49.57 KB, image/png)
2018-02-16 20:21 UTC, roumanet
Details
Example file (16.20 KB, application/vnd.oasis.opendocument.text)
2018-03-07 11:24 UTC, Buovjaga
Details
Open Office 4 (74.77 KB, image/png)
2018-03-07 17:28 UTC, roumanet
Details
Test file with 'indent after text' equal on both paragraph's style. (16.82 KB, application/vnd.oasis.opendocument.text)
2018-03-07 17:59 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description roumanet 2018-02-16 17:43:59 UTC
Created attachment 139951 [details]
Formating error with bullets

1) Start a new Writer document
2) Use Lorem Ipsum text to have some content (https://loremipsumgenerator.com/generator/?n=2&t=p)
3) edit "Corps de texte" formating style (not the default style) to have a spacing at 3 cm from the end
4) apply this style to all the text : a spacing between right of the document and characters is set (3 cm)
5) Press [F12] or use bullets icon

the text goes to the end right, without spacing.
Comment 1 roumanet 2018-02-16 17:48:16 UTC
(have to explain : end spacing)
Comment 2 Jean-Baptiste Faure 2018-02-16 20:13:41 UTC
I reproduce with LO 6.0.2.0+ but I do not know if it is a bug or not.

Best regards. JBF
Comment 3 roumanet 2018-02-16 20:21:41 UTC
Created attachment 139954 [details]
Word comparison

I suppose it's a bug because doing same operations on Word, gives the right result. See attachment
Comment 4 Buovjaga 2018-03-07 11:24:57 UTC
Created attachment 140425 [details]
Example file

Created with

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 856c57f20f9b07c686a854e0ccbb6ee3b0ee4791
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 7th 2018
Comment 5 Buovjaga 2018-03-07 16:38:32 UTC
Paging UX: should we mimic Microsoft Office in this?
Comment 6 roumanet 2018-03-07 17:28:10 UTC
Created attachment 140450 [details]
Open Office 4

@buovjaga of course, it's not a "Microsoft cloning or not", it's a setting that said "Indent after text", meaning "up to the marge"
Formating style is important for book or course writing.
Bug is present in OpenOffice 4 too !
Comment 7 Buovjaga 2018-03-07 17:32:58 UTC
Ok, fine, let's forget about UX.
Comment 8 Regina Henschel 2018-03-07 17:35:36 UTC
That is the known problem, that right indent is ignored, if the paragraph belongs to a list. It is surely a bug.

*** This bug has been marked as a duplicate of bug 83532 ***
Comment 9 roumanet 2018-03-07 17:41:48 UTC
Thanks Regina ! I confirm the description is right on bug 83532
I don't know but you can close this one (because my english isn't so good as the description on bug 83532)
This would avoid archiving too much datas and will reduce bug list ? Thanks
Comment 10 m.a.riosv 2018-03-07 17:59:59 UTC
Created attachment 140453 [details]
Test file with 'indent after text' equal on both paragraph's style.

With the same 'indent after text' on both paragraph styles, I think it's working fine. Buovjaga file modifyed to have the same 'indent after text' and paragraph justification to see better the matter.