Download it now!
Bug 115792 - Cursor is in the wrong position after pasting text
Summary: Cursor is in the wrong position after pasting text
Status: CLOSED DUPLICATE of bug 114675
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Paste Cell-Edit-Mode
  Show dependency treegraph
 
Reported: 2018-02-17 00:16 UTC by Alan
Modified: 2018-03-02 19:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alan 2018-02-17 00:16:51 UTC
Description:
When editing text in a cell in Calc by pasting some text the cursor is at the beginning of the pasted text and not at the end. This has changed since Libreoffice 5 where the cursor was placed at the end of the pasted text.

Steps to Reproduce:
1.Put some text in a cell in Calc
2.Copy some other text from somewhere else
3.Edit the cell in step 1, move somewhere in the middle
4.Paste the copied text

Actual Results:  
cursor is at the beginning of the pasted text

Expected Results:
cursor should be at the end of the pasted text, as was the behavior in previous versions of Calc


Reproducible: Always


User Profile Reset: No



Additional Info:
Specific version details:
Version: 6.0.1.1
Build ID: 1:6.0.1~rc1-0ubuntu0.17.10.1~lo1
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: group



User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Aron Budea 2018-02-17 01:08:59 UTC
Confirmed with LO 6.0.1.1 / Windows 7.

Bibisected to the following commit with repo bibisect-win32-6.0. Seems to be a change from the editengine GSoC. Adding Cc: to Varun Dhall, please take a look sometimes if you can.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=3278cbf7dcf0c72c125fb4ba14e2b24faf267d9c
author		Varun Dhall <varun.dhall@studentpartner.com>	2017-06-13 01:36:06 +0530
committer	Michael Stahl <mstahl@redhat.com>	2017-06-15 14:12:40 +0200

EditEngine: Added EditEngine ODF format for Windows
Comment 2 Thomas Lendo 2018-02-26 12:02:32 UTC
Is this a duplicate of Bug 114675 (Pasting text leaves the cursor in front of the pasted text)?
Comment 3 Eike Rathke 2018-03-02 19:04:22 UTC
It is.

*** This bug has been marked as a duplicate of bug 114675 ***