Bug 115802 - Problem with Persian language text in PDF
Summary: Problem with Persian language text in PDF
Status: RESOLVED DUPLICATE of bug 104597
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-02-17 12:50 UTC by Saad
Modified: 2020-06-24 12:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Contains .odt and .pdf files (44.68 KB, application/x-zip-compressed)
2018-02-24 12:05 UTC, Saad
Details
pdf import printscreen (102.65 KB, image/png)
2018-02-27 21:36 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Saad 2018-02-17 12:50:34 UTC
Description:
When i open a pdf file that contains Persian text, the word characters are reverse. for example the "Word" shows "droW".
کلمه shows هملک

in all LibreOffice programs. this problem there is in many PDF programs, but the "Foxit" programs or "Wondershare PDFElement" program there is not. Please you fix it too. Thanks.

Actual Results:  
When i open a pdf file that contains Persian text, the word characters are reverse.

Expected Results:
Show words of Persian text true.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 Jacques Guilleron 2018-02-24 11:36:34 UTC
Hi Saad,

Would you be so kind to provide an .odt persian file sample and its PDF transfer?
Thank you very much.
Comment 2 Saad 2018-02-24 12:05:37 UTC
Created attachment 140109 [details]
Contains .odt and .pdf files
Comment 3 Jacques Guilleron 2018-02-24 15:50:00 UTC
Thank you Saad.

I didn't reproduce with
LO 6.0.1.1 (x64) Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL
Lets see if somebody else find it.
Comment 4 raal 2018-02-27 21:35:36 UTC
This seems to have begun at the below commit.
Adding Cc: to Thorsten Behrens ; Could you possibly take a look at this one?
Thanks

4939051176402d6a7d6c1d5d67397799e6b15b2c is the first bad commit
commit 4939051176402d6a7d6c1d5d67397799e6b15b2c
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Fri Sep 18 10:48:28 2015 +0800

    source-hash-ff140bb6b8b109f14c270ff059f0b8d71dab5d6c
    
    commit ff140bb6b8b109f14c270ff059f0b8d71dab5d6c
    Author:     Thorsten Behrens <tbehrens@suse.com>
    AuthorDate: Thu Mar 21 00:37:28 2013 +0100
    Commit:     Thorsten Behrens <tbehrens@suse.com>
    CommitDate: Thu Mar 21 00:54:16 2013 +0100
    
        Remove StringMirror UNO service.
    
        This was a kludge from back in the day when pdfimport was an
        extension and could not link against office libs.
    
        While at it, fix mirror method to handle unicode surrogates
        correctly.
    
        Change-Id: I3582a7870efdfea50446d3604a185025b1d5a196
Comment 5 raal 2018-02-27 21:36:14 UTC
Created attachment 140196 [details]
pdf import printscreen
Comment 6 Xisco Faulí 2018-02-28 09:15:07 UTC
It looks the same bug as bug 104597 ( bibisect commit is the same ).
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 104597 ***