Bug 115816 - Sidebar Gallery preview list box context menu has two Insert menu items
Summary: Sidebar Gallery preview list box context menu has two Insert menu items
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0 target:6.1.0.1 target:6.0.6
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-02-17 23:32 UTC by Jim Raykowski
Modified: 2018-07-05 15:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Raykowski 2018-02-17 23:32:28 UTC
The preview list context menu has two Insert menu items. The one at the beginning inserts the gallery item. The one at the bottom of the list does nothing.  

To reproduce:

1. open the Sidebar Gallery
2. right click on any image in the preview list

result: context menu popup with
Insert
Insert As Background >
Preview
Title
Delete
Copy
Insert
Comment 1 Jacques Guilleron 2018-02-18 08:42:21 UTC
Hi Jim,

I reproduce with
LO 6.1.0.0.alpha0+ Build ID: 3c913c3844acae8ee0d80ab174133bdc7677efea
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-02-14_00:19:27
Locale: fr-FR (fr_FR); Calc: CL
and
LO 5.4.0.0.alpha0+ Build ID: 3a36cf434fb4a967c9ea767cb7ac5f4da0502a0d
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-04-28_06:33:58
Locale: fr-FR (fr_FR); Calc: CL
but not in
LO 5.3.7.1 Build ID: 376eaac300a303c4ad2193fb7f6a7522caf550b9
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR); Calc: CL
Comment 2 Xisco Faulí 2018-06-20 18:02:59 UTC
Regression introduced by:

author	Caolán McNamara <caolanm@redhat.com>	2017-04-21 11:15:39 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2017-04-21 12:11:35 +0100
commit	d581ef6ee2d448ff30b77236006b6355f41f7449 (patch)
tree	44a197fd9a335b446749b995ae69d6151345ce3e
parent	26930dfffe791de7d0c88d1a6dcb15498d6f6883 (diff)
restore copy/paste menu entries

Bisected with: bibisect-linux-64-5.4

Adding Cc: to Caolán McNamara
Comment 3 Caolán McNamara 2018-06-20 20:18:36 UTC
looks like these were always there, but disabled so hidden in the past, then when I enabled them there's the apparently duplicated entries, the last one is supposed to be a paste into the gallery.
Comment 4 Commit Notification 2018-06-21 14:46:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=84fd1f453b5db67d5846e44b3e1b0cb14d0a5eb4

Resolves: tdf#115816 second 'Insert' menu is paste

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2018-06-21 19:53:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=22c451df33b733440f24c1feb6380d31240d55e6&h=libreoffice-6-1

Resolves: tdf#115816 second 'Insert' menu is paste

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Jacques Guilleron 2018-06-22 09:19:16 UTC
Hi Jim, Xisco, Caolán,

The second "Insert"in context menu is now replaced by "Paste" in
LO  6.2.0.0.alpha0+ Build ID: 4a82543b3419339ae554485c582a80c41a57c417
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-06-22_06:30:14
Locale: fr-FR (fr_FR); Calc: CL
Thank you Caolán.
Comment 7 Commit Notification 2018-06-22 15:50:35 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=68a37c46f21daaedcae479ccce9889ee0459e745

Resolves: tdf#115816 simpler fix for master

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-07-05 15:06:24 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=74b897f9c578cb0b64124ef9563f2355680c8d84&h=libreoffice-6-0

Resolves: tdf#115816 second 'Insert' menu is paste

It will be available in 6.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.