Bug 115818 - Image disappears while editing a document or on autosave
Summary: Image disappears while editing a document or on autosave
Status: RESOLVED DUPLICATE of bug 120515
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: AutoSave-AutoRecovery-Backup Writer-Images
  Show dependency treegraph
 
Reported: 2018-02-18 01:00 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-02-16 15:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (186.61 KB, application/vnd.oasis.opendocument.text)
2018-02-18 17:11 UTC, Yousuf Philips (jay) (retired)
Details
Bibisect log (2.91 KB, text/plain)
2018-03-21 15:46 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2018-02-18 01:00:33 UTC
steps (option 1):
1. change Tools > Options > Load/Save > General > Save AutoRecovery to 1 minute
2. open attached sample
3. notice Image1 on page 2
4. modify the file to activate autorecovery
5. once autorecovery is saved, Image1 will disappear

image will reappear if you save the file as a new file, or save the file and reopen it.

steps (option 2):
1. open attached sample
2. notice Image1 on page 2
3. select text starting at the line before 'Proposals' heading all the way up to 'Requirements / User Stories' heading and press delete
4. notice that Image1 has disappeared

image will reappear if you undo, save the file as a new file, or save the file and reopen it.

Version: 6.1.0.0.alpha0+
Build ID: acb43c0b8efbfb841e7b40603d75a8432eb21f21
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-01-09_01:20:44
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 1 Telesto 2018-02-18 11:12:27 UTC
No sample file attached :-)
Comment 2 Yousuf Philips (jay) (retired) 2018-02-18 17:11:07 UTC
Created attachment 139976 [details]
sample
Comment 3 Telesto 2018-02-18 21:29:02 UTC
Repro with
Version: 6.1.0.0.alpha0+
Build ID: b87fe45e8b087a315a65b92bf9c168b1e4c5cc00
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-02-16_23:14:35
Locale: nl-NL (nl_NL); Calc: CL

No repro with
Version: 5.2.5.0.0+
Build ID: a4d4fbeb623013f6377b30711ceedb38ea4b49f8
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-2, Time: 2016-12-24_14:43:55
Locale: nl-NL (nl_NL); Calc: CL

Image isn't actually gone. It's somewhere at the bottom of the page and transparent.
Comment 4 Xisco Faulí 2018-02-27 12:30:01 UTC
*** Bug 116042 has been marked as a duplicate of this bug. ***
Comment 5 Xisco Faulí 2018-02-27 17:36:32 UTC
I can't reproduce it in

Version: 6.1.0.0.alpha0+
Build ID: fa2dd2ba03f8be1f148dca8f6164daaf7bbf7d96
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

@Jay, Telesto, Do you still reproduce it on master ?
Comment 6 Yousuf Philips (jay) (retired) 2018-02-27 18:25:06 UTC
Still repo

Version: 6.1.0.0.alpha0+
Build ID: 96d551636e9179eb6874a5156b191ef3bff0a10c
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 7 Telesto 2018-03-21 15:46:08 UTC
Created attachment 140794 [details]
Bibisect log

Bisected to:

author	Miklos Vajna <vmiklos@collabora.co.uk>	2017-11-29 17:17:45 +0100
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2017-11-30 08:07:09 +0100
commit	343af46fc301a984929e071d477b8fb9f211e289 (patch)
tree	aa29a1fbd386c88acb3310933bacc2d411b47c6c
parent	c26f644db80e10f755911d277aac0e1d42731d29 (diff)
ODT filter: make sure we have a layout before export
It is expected that the commandline --convert-to switch gives mostly the
same result as save-as on the UI, but this was not the case for ODT, as
the convert-to case had no layout available.

As a result the explicit width of table columns or soft page-breaks were
missing from the export result in the convert-to case.

Given that Word formats already calculate the layout before export and
during crashtesting we already wait for the OnLayoutFinished even before
export, just enable calculating the layout before ODT export as well to
shrink the cmdline vs GUI differences.

[ No testcase: saving
writerperfect/qa/unit/data/writer/epubexport/table.fodt with the writer8
export filter would be a reproducer for this, but the test doesn't fail
without the fix even aftet not calling CalcLayot() via the
mustCalcLayoutOf() override, so I'm out of ideas right now how to test
this. ]
Comment 8 Telesto 2018-03-21 15:48:40 UTC
STR
1. Download the attached file
2. Press Save -> image "disappears" 
3. File -> reload -> everything back to normal
Comment 9 Telesto 2018-03-21 15:49:10 UTC Comment hidden (obsolete)
Comment 10 Xisco Faulí 2018-06-05 21:05:49 UTC
Adding Cc: to Miklos Vajna
Comment 11 Miklos Vajna 2019-02-16 15:12:52 UTC
I reverted the problematic commit for bug 120515 already, so I guess this can be closed as a duplicated.

*** This bug has been marked as a duplicate of bug 120515 ***