Bug 115835 - Calc - Copying Cells in a Row with Conditional formatting - Conditional formatting not copied
Summary: Calc - Copying Cells in a Row with Conditional formatting - Conditional forma...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard: target:6.1.0 target:6.0.3
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-02-19 03:21 UTC by Ashok
Modified: 2018-03-15 15:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ashok 2018-02-19 03:21:47 UTC
Description:
LibreOffice Calc Ver 6.01 x64 on Windows 10 64 Bit
If you try to copy a range of cells in a row with conditional formatting only the conditional formatting of the first cell in the range is copied.
For Example if Range A1:C1 has conditional formatting and if you select the Range Range A1:C1 and copy to Range A2:C2 then only the cell A2 has the conditional formatting.  The other cells (B2 and C2) does not have the conditional formatting of B1 and C1.  The issue is there only when you copy rows.  When you copy columns say range E1:E3 to F1:F3 conditional formatting of all cells are copied.  The problem started, I think, from Version 5.2 or 5.3 

Steps to Reproduce:
1.  Create a Range of Cells in a Row say A1:C1 with Conditional Formatting 
2.  Select the cells in the Row (A1:C1) and Copy to another Row (Say A2:C2)
3.

Actual Results:  
Only Cell A2 had conditional Formatting

Expected Results:
The conditional Formatting of the other cells should have been copied 


Reproducible: Always


User Profile Reset: No



Additional Info:
The issue is there only when rows are copied.  Works perfectly well when columns are copied.


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; rv:11.0) like Gecko
Comment 1 Ashok 2018-02-19 03:36:00 UTC
Tried to create a sample document with the error to attach
Found that if you save the document and then open it, all the cells have the conditional Formatting and there is no issue.
Comment 2 IWAMOTO 2018-02-19 06:26:09 UTC
Do not reproduce.

Version: 6.0.1.1 (x64)
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
Locale: ja-JP (ja_JP); 
OS:Winsows7 Home Premium x64
Comment 3 raal 2018-02-19 17:19:38 UTC
This seems to have begun at the below commit.
Adding Cc: to Markus Mohrhard ; Could you possibly take a look at this one?
Thanks

471e165665cd14f93d6df2fb5c0adb6efa95bca8 is the first bad commit
commit 471e165665cd14f93d6df2fb5c0adb6efa95bca8
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Mar 16 19:36:38 2017 -0700

    source sha:d4bdac90c3b12d1de74b99786f2e830ee2ae18dc
author    Markus Mohrhard <markus.mohrhard@googlemail.com>    2017-03-16 21:46:57 +0100
committer    Markus Mohrhard <markus.mohrhard@googlemail.com>    2017-03-17 02:31:45 +0000
commit    d4bdac90c3b12d1de74b99786f2e830ee2ae18dc (patch)
tree    84b91200cb3205ef916ff687fa90f9c3ded8cca9
parent    01667d040d9280ee2d918a4bc4a5147e870c039c (diff)
CopyOneCellFromClip also copies one row ranges, tdf#106242
Comment 4 Commit Notification 2018-02-23 10:34:39 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c557889748292d25996ea8f587d7564c74e6f121

copy multiple single row cond formats correctly, tdf#115835

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2018-02-23 17:25:48 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a5ce0b396fdf48bba13d9e0433614d0e0e4368ea

add test for tdf#115835

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2018-03-15 15:49:44 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=15443038c4b8d4c1e7d1aa32df72f41ba93b5b8b&h=libreoffice-6-0

copy multiple single row cond formats correctly, tdf#115835

It will be available in 6.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.