Bug 115854 - In the text justified on some occasions (see example) it is difficult to point a character to edit it.
Summary: In the text justified on some occasions (see example) it is difficult to poin...
Status: RESOLVED DUPLICATE of bug 105913
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-02-19 13:55 UTC by Braciolo
Modified: 2019-03-12 18:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
this attachment shows the error (15.63 KB, application/vnd.oasis.opendocument.text)
2018-02-19 13:57 UTC, Braciolo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Braciolo 2018-02-19 13:55:17 UTC
Description:
In the text justified on some occasions (see example) it is difficult to point a character to edit it.
The "character pointing scheme" is not aligned with the text and this produces difficulties in the case of editing the text. If you point to a certain character to eliminate it, the result is to delete a different character shifted by some forward or backward positions. For example (see attached file): if you want to delete the character "(" and point to the immediately preceding position and press "delete" the result is the deletion of the last character "a" of the word "Settimana"

Steps to Reproduce:
1. Using the attached file, try to delete char "("
2.
3.

Actual Results:  
The deleted character is another

Expected Results:
the deleted character is the one selected


Reproducible: Always


User Profile Reset: No



Additional Info:
 Using the attached file, with the same font.


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Braciolo 2018-02-19 13:57:15 UTC
Created attachment 139992 [details]
this attachment shows the error

this attachment shows the error
Comment 2 Braciolo 2018-02-19 18:40:53 UTC
With ubuntu (17.10) and Libreoffice 5.4.2.2 the problem does not occur.
Note: the font to reproduce the problem (in Windows) must be Linux Libertine G, 12
Comment 3 Braciolo 2018-02-20 08:59:25 UTC
With Windows x64
has the problem:
LO 5.3.3.2 x64, LO 5.3.6.1 x64, 5.3.7.2 x64

It does NOT present the problem:
LO 5.0.3.2 x64
Comment 4 IWAMOTO 2018-02-20 09:02:50 UTC
Reproduced.


Version: 6.0.1.1 (x64)
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
Locale: ja-JP (ja_JP); 
OS:Winsows7 Home Premium x64
CPU:Intel(R)celeron(R)2.00GHz
Comment 5 Xisco Faulí 2018-02-22 17:08:45 UTC
Regression introduced by:

author	Khaled Hosny <khaledhosny@eglug.org>	2016-11-02 23:52:06 +0200
committer	Khaled Hosny <khaledhosny@eglug.org>	2016-11-03 00:17:06 +0000
commit 8f2dd1df1d6cc94ebbc1149de72bc6d6dffa6533 (patch)
tree db496889434c484a87b13ffcc4650d65e6672129
parent c8be45889217c555e4bec92af838d0524ceba4e0 (diff)
Revert "Revert "Enable the new text layout engine by default""
This reverts commit 3950166877bf1308f9e449992e20b558342af825.

Bisected with: bibisect-linux-64-5.3

Adding Cc: to Khaled Hosny
Comment 6 Khaled Hosny 2018-02-24 14:10:52 UTC
This needs to bisected with SAL_USE_COMMON_LAYOUT env var set.
Comment 7 QA Administrators 2019-02-25 03:46:54 UTC Comment hidden (obsolete)
Comment 8 Khaled Hosny 2019-02-27 16:51:14 UTC
Can’t reproduce with 6.2, looks like a duplicate of bug 105913, re-open if you can reproduce.

*** This bug has been marked as a duplicate of bug 105913 ***
Comment 9 Xisco Faulí 2019-03-12 18:09:16 UTC
indeed! I can't even reproduce it in

Versió: 6.1.4.2
ID de la construcció: 1:6.1.4-0ubuntu0.16.04.1~lo2
Fils de CPU: 4; SO: Linux 4.15; Renderitzador de la IU: per defecte; VCL: gtk3; 
Configuració local: ca-ES (ca_ES.UTF-8); Calc: group threaded