Download it now!
Bug 115920 - Wizards cause Writer to crash
Summary: Wizards cause Writer to crash
Status: RESOLVED DUPLICATE of bug 115927
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-21 19:48 UTC by leon244@comcast.net
Modified: 2018-02-22 13:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
gdbtrace.log for wizard crash (27.92 KB, text/x-log)
2018-02-21 21:42 UTC, leon244@comcast.net
Details

Note You need to log in before you can comment on or make changes to this bug.
Description leon244@comcast.net 2018-02-21 19:48:35 UTC
Opening the wizard to do a fax or a letter causes crash.
Steps:
choose Fax wizard from menu
click finish on the wizard dialog
Document recovery dialog opens noting that the application has crashed.
Click <OK> in the dialog, the app closes.
Reopen notes that there was a crash, but nothing to recover

Happens every time the wizard is open, whether for Fax or Letter

Using x86_64 rpm version
Does not happen under the deb version
Comment 1 Julien Nabet 2018-02-21 20:07:48 UTC
On pc Debian testing x86-64 with LO Debian package 6.0.1.1, I don't reproduce this.
I tested with gtk3, gtk, kde4 and gen rendering.

Could you give a try to https://wiki.documentfoundation.org/QA/FirstSteps ?

If you still reproduce this, would it be possible you attach a backtrace? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace)
Comment 2 leon244@comcast.net 2018-02-21 21:42:08 UTC
Created attachment 140045 [details]
gdbtrace.log for wizard crash
Comment 3 leon244@comcast.net 2018-02-21 21:43:40 UTC
I have attached the trace log. I did everything on the First Steps page with no change in behavior.
Yes, it run from the debian package for me but not from the rpm package running under Mageia6
Comment 4 Julien Nabet 2018-02-22 09:19:03 UTC
According to the bt, it seems related to kde rendering.
For the test could you try other renderings, ie:
export SAL_USE_VCLPLUGIN=gtk3
then launch LO from console.

You can also try these:
SAL_USE_VCLPLUGIN=gen
SAL_USE_VCLPLUGIN=gtk
Comment 5 leon244@comcast.net 2018-02-22 12:06:55 UTC
Both SAL_USE_VCLPLUGIN=gen and SAL_USE_VCLPLUGIN=gtk fix the issue.
How can I make this work when I launch from the application menu and not from the console?
Comment 6 leon244@comcast.net 2018-02-22 12:31:23 UTC
Solved for now by placing export SAL_USE_VCLPLUGIN=gtk in my .bashrc file and logging out and then back in.
thank you.
Comment 7 Julien Nabet 2018-02-22 13:19:29 UTC
I don't know, let's put this one as DUP.

*** This bug has been marked as a duplicate of bug 115927 ***