Bug Hunting Session
Bug 115939 - spaces looks off between letters when using arial
Summary: spaces looks off between letters when using arial
Status: RESOLVED DUPLICATE of bug 88991
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2018-02-22 18:55 UTC by Roeland
Modified: 2018-03-02 08:56 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
odt file to test (9.01 KB, application/vnd.oasis.opendocument.text)
2018-02-22 18:55 UTC, Roeland
Details
screenshot on my machine (1.07 KB, image/png)
2018-02-22 18:56 UTC, Roeland
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roeland 2018-02-22 18:55:53 UTC
Created attachment 140062 [details]
odt file to test

I'm typing a text in Writer on Win 7. When i use the arial font I noticed that the spacing between the letters looks quite inconsistent.

I added a test file and a screenshot of the result on my computer. If you check this image, you will notice that the "e" is very close to sthe other letters in some places, and quite distant in other words (the ending of "realisme").
Comment 1 Roeland 2018-02-22 18:56:25 UTC
Created attachment 140063 [details]
screenshot on my machine
Comment 2 Dieter Praas 2018-03-01 17:26:40 UTC
Not reproducible for me with

Version: 6.1.0.0.alpha0+ (x64)
Build ID: d64ce643275e0b2b0dea9e532fc261391dc8793c
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-03-01_03:24:30
Locale: de-DE (de_DE); Calc: CL

Did you enable kerning?
Comment 3 Roeland 2018-03-01 19:53:45 UTC
This is what I use:

Version: 6.0.2.1 (x64)
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU threads: 8; OS: Windows 6.1; UI render: default; 
Locale: nl-BE (nl_BE); Calc: group

pair kerning is on..

Maybe this is windows 7 specific?
Comment 4 V Stuart Foote 2018-03-01 20:12:18 UTC
confirmed on Windows 10 Ent 64-bit en-US (ver 1709) with
Version: 6.0.1.1 (x64)
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: en-US (en_US); Calc: group

On this system the Arial font is version 6.98 (2017 -- 3,338 chars/4,453 glyphs)

And the sample text in the ODT document has a Bold Character effect applied at 100% zoom. Removing the Bold, or increasing or decreasing the zoom gives a different spacing--but 100% is visually misplaced. At different zooms it is fine.

And if I change font to use Arial Unicode MS (version 1.01 93-2000 - 38,197 chars/50,377 glyphs) the string with bold set does not display the same misplacement glitch.

So IIUC this is a lack of Floating Point positioning for Glyphs bug 103322, just weird that what should be a solid font to use is affected.
Comment 5 Xisco Faulí 2018-03-02 08:56:52 UTC
I guess we can close this one as a dupe of bug 88991...

*** This bug has been marked as a duplicate of bug 88991 ***