Bug 115945 - FILESAVE PPTX Labels in chart change (from white and other colors) to black when saving as PPTX
Summary: FILESAVE PPTX Labels in chart change (from white and other colors) to black w...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:6.2.0 target:6.1.0.1
Keywords: implementationError
: 115995 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-22 21:07 UTC by Gerald Pfeifer
Modified: 2019-01-03 18:47 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample document (in ODP) (318.78 KB, application/vnd.oasis.opendocument.presentation)
2018-02-22 21:07 UTC, Gerald Pfeifer
Details
Screenshot before (65.92 KB, image/png)
2018-02-22 21:12 UTC, Gerald Pfeifer
Details
Screenshot after (saved as PPTX) (36.83 KB, image/png)
2018-02-22 21:12 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2018-02-22 21:07:59 UTC
Created attachment 140069 [details]
Sample document (in ODP)

Consider the attached document where the labels in the graph are white.

Saving this as PPTX and reopening the PPTX you'll find the color changed
to black.
Comment 1 Gerald Pfeifer 2018-02-22 21:12:05 UTC
Created attachment 140070 [details]
Screenshot before
Comment 2 Gerald Pfeifer 2018-02-22 21:12:32 UTC
Created attachment 140071 [details]
Screenshot after (saved as PPTX)
Comment 3 Gerald Pfeifer 2018-02-22 21:14:55 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2018-02-23 15:09:41 UTC
Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 74d30155c5067271fb98bacbcb895c215e61678d
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

@Tamas Zolnai, one for you ?
Comment 5 Timur 2018-02-23 16:33:53 UTC
Color from white and other colors is changed to black. Not a regression. 
Looks like implementation error in 4.1.
Comment 6 Justin L 2018-06-28 18:42:04 UTC
(In reply to Timur from comment #5)
> Looks like implementation error in 4.1.

Yup. Just a missing function call. https://gerrit.libreoffice.org/56616
Comment 7 Commit Notification 2018-06-29 08:51:38 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ae2fd281e046b2199ef44777b84518cd3abb2952

tdf#115945 oox export: data label writeRunProperties

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-07-04 19:10:22 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=58284e26fa604edc02b7598cb77a5b272c288320&h=libreoffice-6-1

tdf#115945 oox export: data label writeRunProperties

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Justin L 2018-07-25 05:06:49 UTC
too late to push into "stable" now. Marking as finished.
Comment 10 Aron Budea 2019-01-03 18:47:52 UTC
*** Bug 115995 has been marked as a duplicate of this bug. ***