Download it now!
Bug 115978 - FILESAVE: LibreOffice Calc crash when save file.
Summary: FILESAVE: LibreOffice Calc crash when save file.
Status: CLOSED DUPLICATE of bug 98776
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.5.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: wantBacktrace
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-02-23 18:30 UTC by Luis Fernando
Modified: 2018-02-26 12:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Calc crashes when I try to add a comment. (12.79 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-02-23 18:32 UTC, Luis Fernando
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Fernando 2018-02-23 18:30:15 UTC
Description:
I start to create a new spreadsheet with some basic operations (+, -, / and *). When I try to save the file, LibreOffice calc crashes and start again recovering the file that I was working on.

I tried to export the file to other format, but crashes too.

Steps to Reproduce:
1. Create a simple spreadshet with some formulas and comments on some cells.
2. Try to save in ods format or export file to other format, by clicking on toolbar icon or using menu.
3. Libreoffice crashes before show up the dialog box to select location and specify filename.

I will attach a sample file with problem ocurring when add a comment in a cell.

Actual Results:  
After crashes, LibreOffice starts recovering file that I was working on. After I remove comments on cells, I could save the file.

Expected Results:
File should be saved, even without comments.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Versão: 5.4.5.1
ID da versão: 1:5.4.5-0ubuntu0.17.10.1
Processos do CPU: 8; SO: unknown; Gestão da interface: padrão; VCL: kde4; 
Configuração regional: pt-BR (pt_BR.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.168 Safari/537.36 OPR/51.0.2830.40
Comment 1 Luis Fernando 2018-02-23 18:32:51 UTC
Created attachment 140096 [details]
Calc crashes when I try to add a comment.

When I wrote a comment on any yellow cells and try to save the file, LibreOffice crashes.
Comment 2 Xisco Faulí 2018-02-23 18:35:18 UTC Comment hidden (obsolete)
Comment 3 Xisco Faulí 2018-02-23 18:39:52 UTC
oh, I see your environment is kde4.
Closing as RESOLVED DUPLICATED of bug 115971

*** This bug has been marked as a duplicate of bug 115971 ***
Comment 4 Luis Fernando 2018-02-23 18:57:45 UTC
I follow your instructions to use another renderer without success.

I reset again my profile and didn't have success too.

I'm using kde5 (kde-plasma-5.10.5, kde-framework-5.38.0, qt-5.9.1 and kernel 4.15.5-041505-generic) on a Kubuntu 17-10.

As I sad before, the bug happens only when you add a comment to a cell on a spreadsheet. After I remove the comment, save works like a charm.

Best regards.

Luis Fernando.
Comment 5 Julien Nabet 2018-02-23 21:12:56 UTC
Luis: could you give a try to https://bugs.documentfoundation.org/show_bug.cgi?id=115920#c4 ?

Indeed, if you try to use gtk rendering for example and don't have gtk libs, LO will use your by default rendering (here kde)
Comment 6 Xisco Faulí 2018-02-24 10:06:43 UTC
*** Bug 115985 has been marked as a duplicate of this bug. ***
Comment 7 Xisco Faulí 2018-02-24 11:12:38 UTC
Closing as dupe of bug 98776

See comment 25 -> https://bugs.documentfoundation.org/show_bug.cgi?id=98776#c25

*** This bug has been marked as a duplicate of bug 98776 ***
Comment 8 Luis Fernando 2018-02-26 12:58:22 UTC
Using LO  as described in one comment (sorry, I don't remember which number), works gracefully.

Thank you!

Versão: 6.0.1.1
ID de compilação: 60bfb1526849283ce2491346ed2aa51c465abfe6
Threads da CPU:8; SO:Linux 4.15; Realizador da interface: padrão; VCL: kde4; 
Local: pt-BR (pt_BR.UTF-8); Calc: group