Bug Hunting Session
Bug 116010 - Overlapping text with substitution font - ligature handling bug
Summary: Overlapping text with substitution font - ligature handling bug
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Font-Rendering HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2018-02-25 19:11 UTC by Telesto
Modified: 2019-08-10 12:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (90.22 KB, image/jpeg)
2018-02-25 19:12 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-02-25 19:11:54 UTC
Description:
Overlapping text with substitution font 

Steps to Reproduce:
1. Open attachment 135454 [details] (bug 111681)



Actual Results:  
"Effect" renders badly

Expected Results:
Shouldn't happen


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 6.1.0.0.alpha0+
Build ID: b87fe45e8b087a315a65b92bf9c168b1e4c5cc00
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-02-16_23:14:35
Locale: nl-NL (nl_NL); Calc: CL

but not in
Versie: 5.2.4.2 
Build ID: 3d5603e1122f0f102b62521720ab13a38a4e0eb0
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: GL; 
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Telesto 2018-02-25 19:12:30 UTC
Created attachment 140140 [details]
Screenshot
Comment 2 Timur 2018-02-26 09:59:19 UTC
No repro in Win 7 with master.
Comment 3 Buovjaga 2018-03-08 17:42:03 UTC
No repro, but there is something fishy with the "eff" - I am not able to select the individual characters in it! Only the whole eff. I looked into content.xml, but there is nothing weird there, just
<text:span text:style-name="T2">effect size sampling distributions</text:span>

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: b8fe96f1da2c42c04a8094ca8c57d49763b7bded
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 8th 2018
Comment 4 Buovjaga 2018-03-08 17:43:06 UTC
Ok, so in 3.6 I *am* able to select individual characters. Let's just go crazy and set this to NEW and request bisection.
Comment 5 Xisco Faulí 2018-03-14 19:43:06 UTC
I can't reproduce the original report in

Version: 6.1.0.0.alpha0+
Build ID: 6a9326803c01f4c9bc7da855053ce4e80646fad8
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

But I can reproduce the problem described by Buovjaga in comment 3. Let's assume they're related.

author	Khaled Hosny <khaledhosny@eglug.org>	2013-05-06 11:08:29 +0200
committer	Khaled Hosny <khaledhosny@eglug.org>	2013-05-06 17:22:31 +0200
commit	bff8fa97e16f0f06fddc5545ea36c8bd2b18a580 (patch)
tree	68f92f1622770a178a770f802ec8f6b4db3e1a3b
parent	f0393d7ff69011a16b100541ef18e5090544e4a1 (diff)
Enable HarfBuzz by default
HarfBuzz integration should be functional now, so to give it more wider
testing it is made now a required dependency on non-Windows non-Mac OSs.
By default text layout is now done by HarfBuzz but ICU LayoutEngine is
kept as a fallback and can be enabled with SAL_USE_ICULE env variable.

After 4.1.x is branched, ICU LayoutEngine should be removed completely.

Bisected with: bibisect-41max

Adding Cc: to Khaled Hosny
Comment 6 Khaled Hosny 2018-03-14 20:21:11 UTC
It might be a ligature handling bug, try appending “:-liga” to the font name and see if any of the issues reported here are still reproducible. I’m starting to believe that we have some serious issues dealing with ligatures in the layers above VCL.
Comment 7 Buovjaga 2018-03-15 07:06:52 UTC
(In reply to Khaled Hosny from comment #6)
> It might be a ligature handling bug, try appending “:-liga” to the font name
> and see if any of the issues reported here are still reproducible. I’m
> starting to believe that we have some serious issues dealing with ligatures
> in the layers above VCL.

Yes, that solves my observed selection problem!

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 6a9326803c01f4c9bc7da855053ce4e80646fad8
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 14th 2018
Comment 8 Khaled Hosny 2019-06-19 01:38:54 UTC
I can't reproduce any of the issues described here with 6.2.4.2, do anyone else still reproduce?
Comment 9 Johnny_M 2019-07-14 21:49:48 UTC
(In reply to Khaled Hosny from comment #8)
> I can't reproduce any of the issues described here with 6.2.4.2, do anyone
> else still reproduce?

I can reproduce the issue in comment 3 / comment 7 with:
Version: 6.2.4.2
Build ID: 1:6.2.4-0ubuntu0.19.04.1
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: de-DE (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 10 Khaled Hosny 2019-07-16 18:39:13 UTC
I can not reproduce on Windows and macOS, do you have Lato font, if not can you export to PDF and attach the file so I can see what replacement font was used?
Comment 11 Khaled Hosny 2019-07-17 00:26:32 UTC
Closing as no one can reproduce the overlap. The selection of text with ligatures is a different issue that I think is already reported.
Comment 12 Johnny_M 2019-08-10 12:53:03 UTC
(In reply to Khaled Hosny from comment #10)
> I can not reproduce on Windows and macOS, do you have Lato font, if not can
> you export to PDF and attach the file so I can see what replacement font was
> used?

Done in bug 83581 comment 16. That bug seems to cover the selection of text with ligatures issue.