Bug 116018 - FILEOPEN - draw no more able to open .pub files
Summary: FILEOPEN - draw no more able to open .pub files
Status: RESOLVED FIXED
Alias: None
Product: Document Liberation Project
Classification: Unclassified
Component: libmspub (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Linux (All)
: medium normal
Assignee: David Tardon
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-02-25 23:13 UTC by Roberto Venco
Modified: 2018-02-28 12:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Descpription is in the Comment above (303.15 KB, application/pdf)
2018-02-25 23:13 UTC, Roberto Venco
Details
Whay I have to see (more or less) (1.47 MB, application/pdf)
2018-02-26 19:18 UTC, Roberto Venco
Details
This is the .PUB original file (7.79 MB, application/vnd.ms-publisher)
2018-02-26 19:23 UTC, Roberto Venco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roberto Venco 2018-02-25 23:13:08 UTC
Created attachment 140142 [details]
Descpription is in the Comment above

In the new version of Draw, opening a .pub document results in an almost completely empty document.
The issue is both in Linux and Windows.
As you can see in the attachemnet: "com 28 gennaio 2018.pdf" is the "real" result of a PDF export of the "com 28 gennaio 2018.pub"; the "com 28 gennaio 2018-bugged.pdf" is the actual result of the export of the "com 28 gennaio 2018.pub".

Regards
Roberto
Comment 1 Xisco Faulí 2018-02-26 16:45:56 UTC Comment hidden (obsolete)
Comment 2 Roberto Venco 2018-02-26 19:18:05 UTC
Created attachment 140163 [details]
Whay I have to see (more or less)

In the file PDF you can see what I have to see (more or less): in fact, this is the PDF file of the .pub following...
Comment 3 Roberto Venco 2018-02-26 19:23:29 UTC
Created attachment 140164 [details]
This is the .PUB original file

This is the original .pub file: as you can see compared to the "what I have to see" linked file, it is very very poor in informations
Comment 4 Roberto Venco 2018-02-26 19:25:21 UTC
Comment on attachment 140142 [details]
Descpription is in the Comment above

This file show the PDF export of the .PUB attached file
Comment 5 Xisco Faulí 2018-02-27 09:54:25 UTC
Regression introduced by:

author	David Tardon <dtardon@redhat.com>	2018-01-02 13:40:57 +0100
committer	David Tardon <dtardon@redhat.com>	2018-01-02 16:58:13 +0100
commit	a3488acbeb3b618cf5b6b1a93608c58d0eb9d646 (patch)
tree	00eef2aef08ebab02ea6c53c39874fb4e16427eb
parent	269f12c8e8c9d43f0b84a40405eed53daef72cfe (diff)
upload libmspub 0.1.3

Bisected with:

Adding Cc: to David Tardon
Comment 6 Xisco Faulí 2018-02-27 09:54:45 UTC
Bisected with: bibisect-linux64-6.1