Bug Hunting Session
Bug 116042 - Images disappears spontaneously LibO 6.1.0.0
Summary: Images disappears spontaneously LibO 6.1.0.0
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Impress-Images imageHandling-regressions
  Show dependency treegraph
 
Reported: 2018-02-26 18:34 UTC by Telesto
Modified: 2018-03-08 10:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-02-26 18:34:49 UTC
Description:
Images disappears spontaneously. Might be related to improving image handling (https://tomazvajngerl.blogspot.nl/2018/01/improving-image-handling-in-libreoffice.html)

Similar - but with specific file - bug 98686

Steps to Reproduce:
1. Launch Impress with a fresh empty presentation
2. Set the auto-save to 1 minute (Tools -> Preferences)
3. Attachment 140160 [details] (or probably any other image). Add the image using drag & drop or Insert Image
4. Minimize the screen 
5. Restore the screen after two or three minutes 

No repro with Writer

Actual Results:  
Images disappears

Expected Results:
Shouldn't happen


Reproducible: Always


User Profile Reset: No



Additional Info:
Repro with:
Version: 6.1.0.0.alpha0+
Build ID: e1771058ebc4efc58515ffa60250843274990bac
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-02-24_23:43:30
Locale: nl-NL (nl_NL); Calc: CL


No repro with
Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 4; OS: Windows 6.2; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Xisco Faulí 2018-02-27 12:30:01 UTC
Dupe of bug 115818 ?
Put it back to UNCONFIRMED if you disagree...

*** This bug has been marked as a duplicate of bug 115818 ***
Comment 2 Telesto 2018-02-27 12:47:14 UTC
I disagree:
* Bug 115818 is about Writer. I can't repro this in Writer
* Bug 115818: The image isn't really lost. It's somewhere at the bottom of the page and transparent. See comment 3
Comment 3 Xisco Faulí 2018-02-27 17:48:12 UTC
I've reproduced a similar issue:

1. Launch Impress with a fresh empty presentation
2. Set the auto-save to 1 minute (Tools -> Preferences)
3. Attachment 140160 [details] (or probably any other image). Add the image using drag & drop or Insert Image
4. Wait 1 minute
5. Save the document

-> The image disappears


Version: 6.1.0.0.alpha0+
Build ID: fa2dd2ba03f8be1f148dca8f6164daaf7bbf7d96
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 4 Xisco Faulí 2018-02-27 18:18:52 UTC
Regression introduced by:

author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2018-02-19 21:47:04 +0900
committer	Tomaž Vajngerl <quikee@gmail.com>	2018-02-21 21:32:56 +0100
commit	e48b4275ceee82bd0eb128b2947302b9022e9c89 (patch)
tree	c40d1d0d100c67c7fc8076e34b9d8e0769638d37
parent	6fc75b669438728ba6a4e55d53a79fa0cf006529 (diff)
report the saved mimetype when saving graphic + mime from stream

Bisected with: bibisect-linux64-6.1 

Adding Cc: to Tomaž Vajngerl
Comment 5 Tomaz Vajngerl 2018-02-27 20:42:07 UTC
Always also try the latest master as I'm finding and fixing problems that aren't covered by out automatic tests on regular basis and fixing them.  

Also does it happen when you insert image, save, close, open? Always try this as that would mean the problem is in ODF export. Or save with the release version, then open with the LO master, then that would indicate the problem is with ODF import. If both of them work fine, then the problem is in core handling. 

Actually maybe it would be good to not report bugs regarding images for a week or two and then look into this (and other potential issues) again.
Comment 6 Xisco Faulí 2018-02-28 09:36:46 UTC
(In reply to Tomaz Vajngerl from comment #5)
> Always also try the latest master as I'm finding and fixing problems that
> aren't covered by out automatic tests on regular basis and fixing them.

Yes, still repo in

Version: 6.1.0.0.alpha0+
Build ID: e2cb154195fdc2ffccdb6f5e87cae8b29640b3eb
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

from today
 
> 
> Also does it happen when you insert image, save, close, open? Always try
> this as that would mean the problem is in ODF export. Or save with the
> release version, then open with the LO master, then that would indicate the
> problem is with ODF import. If both of them work fine, then the problem is
> in core handling.

I can reproduce it using the steps from comment 3.

> 
> Actually maybe it would be good to not report bugs regarding images for a
> week or two and then look into this (and other potential issues) again.

IMHO, it's good to reports them even if the feature is under development. they can always get closed if they get fixed 2 weeks later. Otherwise, we take the risk we forget about the issue and it doesn't get fixed
Comment 7 Cor Nouws 2018-03-06 13:19:58 UTC
I see this happening in

 - a new Draw file with freshly pasted images, not yet on disk
 - an existing xls file with images, just open for editing

Version: 6.1.0.0.alpha0+
Build ID: ab63510e104c4b8e42982390357af1281c4b11a7
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-03-05_01:01:02
Locale: nl-NL (nl_NL.UTF-8); Calc: group
Comment 8 Xisco Faulí 2018-03-06 15:42:27 UTC
*** Bug 116133 has been marked as a duplicate of this bug. ***
Comment 9 Telesto 2018-03-08 10:27:33 UTC
No repro with
Version: 6.1.0.0.alpha0+
Build ID: d6b33e49a5e9c51827eda9c5ba16d8daeb27e8af
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-07_23:26:53
Locale: nl-NL (nl_NL); Calc: CL

I still reproduce bug 116133 (marked a duplicate)