Bug 116044 - The Description field in the customize dialog is always empty and disabled
Summary: The Description field in the customize dialog is always empty and disabled
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.0.0.beta1
Hardware: All All
: medium minor
Assignee: Muhammet Kara
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Customize-Dialog
  Show dependency treegraph
 
Reported: 2018-02-26 19:43 UTC by Buovjaga
Modified: 2018-02-27 06:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2018-02-26 19:43:17 UTC
See the commands in Menus, Toolbars or Context menus. In 6.0, the Description field used to have stuff, but now it's always empty.

I tried in safe mode to be sure.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 40c33132cfa6582dfccf17e787f10dd4dbd0819d
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on February 24th 2018

Arch Linux 64-bit
Version: 6.0.1.1
Build ID: 6.0.1-1
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 1 Thomas Lendo 2018-02-26 22:10:14 UTC
Reproduced with Version: 6.1.0.0.alpha0+
Build ID: e1771058ebc4efc58515ffa60250843274990bac
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: group

and Version: 6.1.0.0.alpha0+
Build-ID: 0a46237093c1750ee69ddb6a365098dc1d06b758
CPU-Threads: 4; BS: Linux 4.13; UI-Render: Standard; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-02-21_21:56:55
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

and Version: 6.0.1.1 (x64)
BS: Windows 10.0, UI-Render: Standard

I noticed this some months ago but I thought it's still in progress.
Comment 2 Thomas Lendo 2018-02-26 22:31:44 UTC

*** This bug has been marked as a duplicate of bug 112237 ***
Comment 3 Muhammet Kara 2018-02-27 05:20:32 UTC
(In reply to Thomas Lendo from comment #2)
> 
> *** This bug has been marked as a duplicate of bug 112237 ***

This is not duplicate of bug 112237. The other bug is about already added commands.
Comment 4 Muhammet Kara 2018-02-27 05:56:34 UTC
To see the descriptions:
- If building from source, you need to add --with-help to your autogen.input file.
- If installing a release/dev build, you need to install the local help package for your language.

Otherwise, the description field will come empty and disabled. This is the expected behavior.

To be sure, I have tested again on:
Version: 6.1.0.0.alpha0+
Build ID: 96d551636e9179eb6874a5156b191ef3bff0a10c
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 5 Buovjaga 2018-02-27 06:31:32 UTC
(In reply to Muhammet Kara from comment #4)
> To see the descriptions:
> - If building from source, you need to add --with-help to your autogen.input
> file.
> - If installing a release/dev build, you need to install the local help
> package for your language.
> 
> Otherwise, the description field will come empty and disabled. This is the
> expected behavior.

Ok, I had
--with-help=common
--with-help=html

but apparently that is not enough or the offline html help is not yet working.