Bug Hunting Session
Bug 116047 - LO 6.0.1.1 (x64) calc windows, autofilter freezes
Summary: LO 6.0.1.1 (x64) calc windows, autofilter freezes
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: AutoFilter
  Show dependency treegraph
 
Reported: 2018-02-26 22:42 UTC by rimichl
Modified: 2019-09-25 09:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample calc file that exhibits the problem (181.26 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-02-26 22:46 UTC, rimichl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rimichl 2018-02-26 22:42:31 UTC
Description:
Autofilter function on a field with a lot of text in it not working. Dialog box appears, but I cannot type in the filter text box. It just shows blanks and mouse pointer changes to hourglass.

Autofilter on a field where there isn't too much text works fine.

It worked without problem before upgrade to this version. Spreadsheet has cca 13000 rows. I created sample spreadsheet with 1 field and lots of different values in it, which i am attaching and which is exhibiting this behavior.

Steps to Reproduce:
1.Open attached spreadsheet.
2.Click on the Autofilter arrow
3.Type anything in the text box that appears

Actual Results:  
Blank spaces appear in the text box instead of typed letters. Mouse pointer changes to hourglass.

Expected Results:
I should see filtered results that I could use to narrow my filter.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.0.1.1 (x64)
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 2; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.140 Safari/537.36
Comment 1 rimichl 2018-02-26 22:46:07 UTC
Created attachment 140169 [details]
sample calc file that exhibits the problem

I downloaded and ran the openGL checker, but I'm not sure what the report means. I am attaching it here:

Renderer: GDI Generic
Vendor: Microsoft Corporation
Memory: 256 MB
Version: 1.1.0
Shading language version: N/A


Max texture size: 1024 x 1024
Max texture coordinates: 0
Max vertex texture image units: 0
Max texture image units: 0
Max geometry texture units: 0
Max anisotropic filtering value: 0
Max number of light sources: 8
Max viewport size: 16384 x 16384
Max uniform vertex components: 0
Max uniform fragment components: 0
Max geometry uniform components: 0
Max varying vectors: 0
Max samples: 0
Max draw buffers: 0


GL Extensions: 3
\i0 

GL_WIN_swap_hint
GL_EXT_paletted_texture
GL_EXT_bgra

Core features
v1.1 (100 % - 7/7)
v1.2 (12 % - 1/8)
v1.3 (0 % - 0/9)
v1.4 (0 % - 0/15)
v1.5 (0 % - 0/3)
v2.0 (0 % - 0/10)
v2.1 (0 % - 0/3)
v3.0 (0 % - 0/23)
v3.1 (0 % - 0/8)
v3.2 (0 % - 0/10)
v3.3 (0 % - 0/10)
v4.0 (0 % - 0/14)
v4.1 (0 % - 0/7)
v4.2 (0 % - 0/13)
v4.3 (0 % - 0/23)
v4.4 (0 % - 0/10)
v4.5 (0 % - 0/11)
v4.6 (0 % - 0/11)
vARB 2015 (0 % - 0/12)
OpenGL driver version check (Current: 0, Latest known: ):
 Latest version of display drivers found 
 According the database, you are running the latest display drivers for your video card.
 No multitexturing support 
 This may cause performance loss in some applications.
 No secondary color support 
 Some applications may not render polygon highlights correctly.
 No S3TC compression support 
 This may cause performance loss in some applications.
 No texture edge clamp support 
 This feature adds clamping control to edge texel filtering. Some programs may not render textures correctly (black line on borders.)
 No vertex program support 
 This feature enables vertex programming (equivalent to DX8 Vertex Shader.) Some current or future OpenGL programs may require this feature.
 No fragment program support 
 This feature enables per pixel programming (equivalent to DX9 Pixel Shader.) Some current or future OpenGL programs may require this feature.
 No OpenGL Shading Language support 
 This may break compatibility for applications using per pixel shading.
 No Frame buffer object support 
 This may break compatibility for applications using render to texture functions.
 Few texture units found 
 This may slow down some applications using fragment programs or extensive texture mapping.
Extension verification: 
 GL_EXT_color_subtable  was not found, but has the entry point  glColorSubTableEXT
Comment 2 Kevin Suo 2018-02-28 13:33:04 UTC
Reproducible with:
Version: 6.0.1.1 (x64)
Build ID:60bfb1526849283ce2491346ed2aa51c465abfe6
CPU 线程:4; 操作系统:Windows 10.0; UI 渲染:默认; 
区域语言:zh-CN (zh_CN); Calc: group

set to NEW.


> It worked without problem before upgrade to this version.
Which version is the last one works? Is it 6.0.0?
Comment 3 rimichl 2018-02-28 17:32:42 UTC
I am 90% sure, last working version was version 5.x, not 6.x.
Comment 4 rimichl 2018-03-06 22:28:50 UTC
I have tried version 5.x and the problem was still there. So perhaps I was wrong claiming that version 5.x didn't have the problem.
Comment 5 Xisco Faulí 2018-04-06 08:25:46 UTC
Removing 'possibleRegression' keyword for now. Add the keyword 'regression' if you can confirm it worked in a previous version of LibreOffice...
Comment 6 QA Administrators 2019-04-07 03:44:37 UTC Comment hidden (obsolete)
Comment 7 rimichl 2019-04-08 13:00:03 UTC
Bug still present.

Version: 6.2.2.2 (x64)
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU threads: 2; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: cs-CZ (en_US); UI-Language: en-US
Calc: threaded
Comment 8 rimichl 2019-04-08 13:48:56 UTC
tested with version 3.3 and the problem didn't occur. So i added the word regression to keyword, as instructed.