Download it now!
Bug 116051 - Hidden column causing right border to disappear
Summary: Hidden column causing right border to disappear
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.0.beta1
Hardware: All All
: medium normal
Assignee: Ilhan Yesil
URL:
Whiteboard: target:6.3.0 target:6.2.1
Keywords: bibisected, regression
: 119496 (view as bug list)
Depends on:
Blocks: Regressions-borderline
  Show dependency treegraph
 
Reported: 2018-02-27 05:50 UTC by Chris Severance
Modified: 2019-01-29 11:45 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Calc Hidden line Hidden column demo (7.74 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-03-02 00:27 UTC, Chris Severance
Details
Demo compared befora and after the fix (30.48 KB, image/jpeg)
2019-01-29 08:41 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Severance 2018-02-27 05:50:53 UTC
Description:
When cells with borders are bounded on the right by a hidden column, calc makes the rightmost border lines disappear.


Steps to Reproduce:
1. New spreadsheet, place 9 of any character (a) in a 3x3 matrix.
2. Mark all characters and add full borders.

Note that the rightmost border of column C is visible.

3. Hide column C, hide Row 3

Note that the rightmost border of column B is no longer visible. The bottom border of row 2 is still visible.

4. Print Preview

The rightmost border is not visible in the print preview. The bottom border is visible.


Actual Results:  
The rightmost border is made invisible by a hidden column to the right.

Expected Results:
The rightmost boarder should stay visible whether the column to the right is hidden or visible.


Reproducible: Always


User Profile Reset: No



Additional Info:
Switching to libreoffice-still-5.4.5-1 solves the problem.


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Xisco Faulí 2018-02-27 09:29:04 UTC Comment hidden (obsolete)
Comment 2 Chris Severance 2018-03-02 00:27:07 UTC
Created attachment 140280 [details]
Calc Hidden line Hidden column demo
Comment 4 Xavier Van Wijmeersch 2018-07-31 15:44:34 UTC
can reproduce

Version: 6.2.0.0.alpha0+
Build ID: 83d8331581ab43cf35325ca674cf62d4ba5dc5ad
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group threaded
Comment 5 Xisco Faulí 2018-10-29 18:51:27 UTC
*** Bug 119496 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2019-01-22 13:21:11 UTC
Ilhan Yesil committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/392729c735bb82eecf29bae5527ec786ca293f34%5E%21

tdf#116051 Right border visible after hiding neighbour column

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Timur 2019-01-29 08:41:52 UTC
Created attachment 148721 [details]
Demo compared befora and after the fix

Seems resolved to me. 
Ilhan, can you please mark as Fixed?
When making a fix for master, please also comment on backport if you intend to do it if already done. 
In this case, please see about backport5 to 6.2. 
Thank you.
Comment 8 Xisco Faulí 2019-01-29 09:49:32 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 6d5af783bfd899253908c926853233a99df6f4e0
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Ilhan Yesil, thanks for fixing this!!
Comment 9 Commit Notification 2019-01-29 11:45:44 UTC
Ilhan Yesil committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/49fbb60d32a7e6ebfce4a6f4754f1bc51c6bf264%5E%21

tdf#116051 Right border visible after hiding neighbour column

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.