Download it now!
Bug 116056 - Copy-paste corruption when copying from LibreOffice-generated PDF (if using Calibri font)
Summary: Copy-paste corruption when copying from LibreOffice-generated PDF (if using C...
Status: RESOLVED DUPLICATE of bug 115117
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-27 11:17 UTC by Daniel Grigoras
Modified: 2018-03-20 02:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample ODT (11.80 KB, application/vnd.oasis.opendocument.text)
2018-03-01 11:55 UTC, Daniel Grigoras
Details
Sample PDF (30.50 KB, application/pdf)
2018-03-01 11:55 UTC, Daniel Grigoras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Grigoras 2018-02-27 11:17:12 UTC
Description:
Hi,

I noticed that when copy-pasting from LibreOffice-generated PDFs a character corruption occurs. If I copy-paste "respective owners" from the PDF, what I actually get is "respecnve ooners".

Steps to Reproduce:
-

Actual Results:  
-

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
-


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36 OPR/50.0.2762.67
Comment 1 raal 2018-02-28 22:19:57 UTC Comment hidden (obsolete)
Comment 2 Daniel Grigoras 2018-03-01 11:55:24 UTC
Created attachment 140243 [details]
Sample ODT
Comment 3 Daniel Grigoras 2018-03-01 11:55:37 UTC
Created attachment 140244 [details]
Sample PDF
Comment 4 Daniel Grigoras 2018-03-01 11:56:31 UTC
It seems that in former version, when copy-pasting from LibreWriter-generated PDFs a character corruption or replacement occurred, in that “ti” was always replaced with “n”. In version 6.0.1.1, “ti” becomes “t”. Also “ing” becomes “nn” if you copy such words as living, walking, talking.
Comment 5 Kevin Suo 2018-03-01 14:38:25 UTC
I confirm this on
Version: 6.0.1.1 (x64)
Build ID:60bfb1526849283ce2491346ed2aa51c465abfe6
CPU 线程:4; 操作系统:Windows 10.0; UI 渲染:默认; 
区域语言:zh-CN (zh_CN); Calc: group

Also, I find that, if changing the fonts to Arial and then re-export as pdf, the bug is gone. Thus the bug is font-specific. The current document uses Calibri font.
Comment 6 Xisco Faulí 2018-03-02 08:54:25 UTC
Reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

Probably it has been already reported in the past to LibreOffice's Bugzilla...
Comment 7 Timur 2018-03-02 17:50:10 UTC
Similar Bug 115117 is explained in https://bugs.documentfoundation.org/show_bug.cgi?id=115117#c2 and marked as a duplicate.

*** This bug has been marked as a duplicate of bug 66597 ***
Comment 8 Khaled Hosny 2018-03-20 02:25:57 UTC
Bug 66597 is becoming a kind of meta bugs with different issues lumped together, lets separate different issues.

*** This bug has been marked as a duplicate of bug 115117 ***