Download it now!
Bug 116068 - CRASH: LibreOffice crashes while deleting half of the document
Summary: CRASH: LibreOffice crashes while deleting half of the document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Crash-Assert
  Show dependency treegraph
 
Reported: 2018-02-27 16:50 UTC by Xisco Faulí
Modified: 2019-07-11 08:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (647.90 KB, application/vnd.oasis.opendocument.text)
2018-02-27 16:50 UTC, Xisco Faulí
Details
gdb backtrace (37.86 KB, text/plain)
2018-02-27 16:51 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-02-27 16:50:47 UTC
Created attachment 140185 [details]
sample file

Steps to reproduce:
1.Open attached document
2. Go to page 200 ( easy from the navigator ( F5 )) and put the cursor at the beginning. 
3. Press Ctrl, Go to the last page, and click on the last character to select from page 200 to 400
4. Press delete key
CRASH!

Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: fa2dd2ba03f8be1f148dca8f6164daaf7bbf7d96
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 1 Xisco Faulí 2018-02-27 16:51:13 UTC
Created attachment 140186 [details]
gdb backtrace
Comment 2 Xisco Faulí 2018-02-27 16:54:37 UTC
Not reproducible in

Versión: 6.0.1.1
Id. de compilación: 60bfb1526849283ce2491346ed2aa51c465abfe6
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group

Linux only...
Comment 3 Xisco Faulí 2018-02-27 17:21:10 UTC
@Michael, this crash asserts in the assert added in 5989c5722a9ce424803d8fb7858ad98c10d0601d...
Could you please take a look ?
Comment 4 Telesto 2018-02-27 22:09:54 UTC
Repro
Version: 6.1.0.0.alpha0+
Build ID: 96d551636e9179eb6874a5156b191ef3bff0a10c
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-02-26_23:44:46
Locale: nl-NL (nl_NL); Calc: CL
Comment 5 Xavier Van Wijmeersch 2018-03-12 19:50:03 UTC
repro

Version: 6.1.0.0.alpha0+
Build ID: 43bf50d5ced4b878f747075f8c0f1b32991c290e
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: gtk3; 
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 6 Xisco Faulí 2018-07-10 09:59:51 UTC
Triaging this again....

I can also reproduce the crash in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.13; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)
Comment 7 Telesto 2018-07-10 10:20:54 UTC
(In reply to Xisco Faulí from comment #6)
> Triaging this again....

Maybe related to bug 73095? BT as some similarity with comment 12
Comment 8 Xisco Faulí 2018-07-10 11:00:41 UTC Comment hidden (obsolete)
Comment 9 Xisco Faulí 2018-07-10 11:07:40 UTC
Forgot what I said in my previous commit, I can still reproduce it with gen environment....
Comment 10 Xisco Faulí 2018-07-10 11:46:24 UTC
Also reproducible with the oldest commit from bibisect-43max

Version: 4.2.0.0.alpha1+
Build ID: fc8f44e82de4ebdd50ac5fbb9207cd1a59a927e3
Comment 11 QA Administrators 2019-07-11 02:54:14 UTC Comment hidden (obsolete)
Comment 12 Xisco Faulí 2019-07-11 08:08:05 UTC
I can't reproduce it in

Version: 6.4.0.0.alpha0+
Build ID: 7a0164f0d82d91e2ac481d74cdacfe9a7ad6080f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Probably fixed by M. Stahl... I'd appreciate if someone else can double check...
Closing as RESOLVED WORKSFORME.