Bug 116073 - FILESAVE PPTX Background gradient in chart gets lost when saving as PPTX
Summary: FILESAVE PPTX Background gradient in chart gets lost when saving as PPTX
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: dataLoss, filter:pptx
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2018-02-27 22:55 UTC by Gerald Pfeifer
Modified: 2019-06-04 12:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample document (in ODP) (318.78 KB, application/vnd.oasis.opendocument.presentation)
2018-02-27 22:55 UTC, Gerald Pfeifer
Details
This is how the original looks (65.92 KB, image/png)
2018-02-27 22:56 UTC, Gerald Pfeifer
Details
This is how it looks like after saving as PPTX and reopening that (36.83 KB, image/png)
2018-02-27 22:57 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2018-02-27 22:55:43 UTC
Created attachment 140198 [details]
Sample document (in ODP)

Consider the attached document.

Saving this as PPTX and reopening the PPTX you'll find the gradient
in the background of the chart is lost.  (Not that this was a nice
background, but...)

This was properly imported from a PPTX originally, so an issue with
the export filter I assume?
Comment 1 Gerald Pfeifer 2018-02-27 22:56:38 UTC
Created attachment 140199 [details]
This is how the original looks
Comment 2 Gerald Pfeifer 2018-02-27 22:57:23 UTC
Created attachment 140200 [details]
This is how it looks like after saving as PPTX and reopening that
Comment 3 Buovjaga 2018-03-08 20:12:20 UTC
I repro.

At first I couldn't figure out how to see the gradient setting.
Double-click to edit chart.
Right-click in the outer regions: Format chart area

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: b8fe96f1da2c42c04a8094ca8c57d49763b7bded
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 8th 2018

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 4 QA Administrators 2019-03-09 03:41:39 UTC Comment hidden (obsolete)
Comment 5 Gerald Pfeifer 2019-06-04 12:56:44 UTC
This appears fixed in

  Version: 6.2.3.2
  Build ID: 20(Build:2)
  CPU threads: 4; OS: Linux 5.1; UI render: default; VCL: gtk3; 
  Locale: en-US (en_US.UTF-8); UI-Language: en-US
  Calc: threaded

on openSUSE Tumbleweed (with some local fixes, all of which have
been pushed upstream).


Technically there is a bug left in that the gradient has it's "peak"
at a different spot, but that's a different issue.