Bug Hunting Session
Bug 116085 - Cannot start Certificate Manager with GPG4win v3
Summary: Cannot start Certificate Manager with GPG4win v3
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.1.3 target:6.0....
Keywords: difficultyBeginner, easyHack
: 120005 (view as bug list)
Depends on:
Blocks: Digital-Signatures
  Show dependency treegraph
 
Reported: 2018-02-28 12:22 UTC by Timur
Modified: 2019-09-02 07:48 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2018-02-28 12:22:37 UTC
I use GPG4win and with version 2.3.4 LO can start it's Kleopatra as Certificate Manager. Default path for installation is "C:\Program Files (x86)\GNU\GnuPG" and path for Kleopatra is "C:\Program Files (x86)\GNU\GnuPG\kleopatra.exe".

When I tried to install GPG4win version 3.0.3 I was offered and accepted path "C:\Program Files (x86)\Gpg4win". LO couldn't start Certificate Manager. There was a message "Could not find any certificate manager" in 6.1+ (while there was no message in 5.3).

It's not clear how LO finds Certificate Manager on different platforms and I wrote that in documentation bug. But if this is not some my local issue, then this should be updated.
Comment 1 Timur 2018-03-02 12:33:41 UTC
Also reported in https://bugs.documentfoundation.org/show_bug.cgi?id=114727#c1.
So I'll confirm.
Comment 3 himajin100000 2018-09-21 08:41:22 UTC
I wonder where "bin" folder has gone.
Comment 4 Dieter Praas 2018-09-21 10:59:41 UTC
*** Bug 120005 has been marked as a duplicate of this bug. ***
Comment 5 Cor Nouws 2018-09-27 19:59:16 UTC
see gerrit#61061
Comment 6 Commit Notification 2018-09-30 23:44:02 UTC
Cor Nouws committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=89a60912bba7ffd6f65ea99f4664f343c5025c95

tdf#116085 make sure Certificate Manager is found with GPG4win v3

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-10-01 08:40:12 UTC
Cor Nouws committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=feb475c6594c5520ea50ba74e8c17e8a1815dc1f&h=libreoffice-6-1

tdf#116085 make sure Certificate Manager is found with GPG4win v3

It will be available in 6.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 himajin100000 2018-10-01 13:40:04 UTC
Hmmm...

my kleopatra.exe resides at 
C:\Program Files (x86)\Gpg4win\bin\kleopatra.exe

not 
C:\Program Files (x86)\Gpg4win\kleopatra.exe

weird.
Comment 9 Cor Nouws 2018-10-10 08:32:28 UTC
(In reply to himajin100000 from comment #8)
> Hmmm...
> 

Should word fine now.
Did you test a recent nightly build?
thanks,
Comment 10 Timur 2018-10-30 09:56:10 UTC Comment hidden (obsolete)
Comment 11 Xisco Faulí 2018-10-30 10:20:57 UTC
(In reply to Timur from comment #10)
> Xisco, I think I read there will be 6.0.7.3. Can you push this one there? 
> Cor, can you mark as fixed?

Yes, it will be tagged today. I hope we get enough reviews in time -> https://gerrit.libreoffice.org/#/c/62547/
Comment 12 Commit Notification 2018-10-30 10:32:57 UTC
Cor Nouws committed a patch related to this issue.
It has been pushed to "libreoffice-6-0-7":

https://git.libreoffice.org/core/+/1839856aec8d59a7575f7aceff48f50e1f237e39%5E%21

tdf#116085 make sure Certificate Manager is found with GPG4win v3

It will be available in 6.0.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2018-10-30 12:16:42 UTC
Cor Nouws committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

https://git.libreoffice.org/core/+/caa828920719240bcf0fb4b55ffb0fd6a5dd8b82%5E%21

tdf#116085 make sure Certificate Manager is found with GPG4win v3

It will be available in 6.0.8.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Luc Lalonde 2018-11-27 20:09:00 UTC
I've tested and still see a problem.

The default installation directory for Kleopatra (GPG4Win) is:

C:\Program Files (x86)\GPG4win\bin\Kleopatra.exe

So the patch won't work...  The 'bin' subdirectory search PATH is missing.

This PATH is in the patch instead:

C:\Program Files (x86)\GNU\GnuPG\bin\Kleopatra.exe

I re-installed GPG4win with this path and everything is working fine.

However, it would be nicer if LibreOffice used the Windows PATH environment instead of hardcoding the possible locations of 'Kleopatra'.

Thank You!
Comment 15 Xisco Faulí 2018-11-27 20:12:16 UTC
Hello Luc Lalonde,
Could you please paste the info from Help - about LibreOffice ?
Comment 16 Luc Lalonde 2018-11-27 20:52:19 UTC
I had to re-install again Gpg4win in the default directory (C:\Program Files (x86)\Gpg4win\bin\Kleopatra.exe)

LibreOffice was not able to find any certicates...

So now I'm back to getting the error 'Cannot find the certificate manager'... but at least I can still sign documents.

Here's my setup:

Windows 10, GPG4Win 3.1.5, LibreOffice 6.1.3.2
Comment 17 Luc Lalonde 2018-11-27 20:53:51 UTC
Here you go:

Version: 6.1.3.2 (x64)
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
Threads CPU : 1; OS : Windows 10.0; UI Render : par défaut; 
Locale : fr-CA (fr_CA); Calc: group threaded
Comment 18 Oliver Brinzing 2019-08-11 06:54:03 UTC
this issue is reproducible with "gpg4win-3.1.10.exe" and:
 
Version: 6.3.0.4 (x64)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: 

gpg4win-3.1.10.exe installs to:

C:\Program Files (x86)\Gpg4win
C:\Program Files (x86)\GnuPG

and "C:\Program Files (x86)\Gpg4win\..\GnuPG\bin" is added to PATH

but all *.exe and *.dll files are copied into subfolder "bin", e.g.:

C:\Program Files (x86)\Gpg4win\bin\kleopatra.exe
C:\Program Files (x86)\GnuPG\bin\gpg.exe

"Procmon" shows, LO searches for:

C:\Program Files (x86)\Gpg4win\kleopatra.exe
C:\Program Files\LibreOffice 6.3\program\Gpg4win
C:\Program Files (x86)\GNU\GnuPG\kleopatra.exe
C:\Program Files\LibreOffice 6.3\program\GNU\GnuPG\
C:\Program Files (x86)\GNU\GnuPG\launch-gpa.exe
C:\Program Files\LibreOffice 6.3\program\GNU\GnuPG\
C:\Program Files (x86)\GNU\GnuPG\gpa.exe
C:\Program Files\LibreOffice 6.3\program\GNU\GnuPG\
C:\Program Files (x86)\GNU\GnuPG\bin\kleopatra.exe
C:\Program Files\LibreOffice 6.3\program\GNU\GnuPG\bin\
C:\Program Files (x86)\GNU\GnuPG\bin\launch-gpa.exe
C:\Program Files\LibreOffice 6.3\program\GNU\GnuPG\bin\
C:\Program Files (x86)\GNU\GnuPG\bin\gpa.exe
C:\Program Files\LibreOffice 6.3\program\GNU\GnuPG\bin\
Comment 19 Xisco Faulí 2019-08-12 08:49:04 UTC
@Cor, @Thosten, based on comment 16, should we add 'Gpg4win\\bin\\kleopatra.exe' and 'GnuPG\\bin\\gpg.exe' to aGUIServers[] ?
Comment 20 Thorsten Behrens (CIB) 2019-08-12 09:28:19 UTC
Yep, see https://gerrit.libreoffice.org/77341
Comment 21 Commit Notification 2019-08-13 14:36:13 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/536ab2f3ba1e71badaaf98db9419ca7c7ddd7ac4%5E%21

tdf#116085 add more Gpg4Win binary locations

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2019-08-13 18:55:41 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/4bff74f20a2007860b87e43443bb2f59ff4a3b3a%5E%21

tdf#116085 add more Gpg4Win binary locations

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2019-08-13 20:58:31 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/c34c9a6eab23bcc43cf7adce365e16abc6cec58a%5E%21

tdf#116085 add more Gpg4Win binary locations

It will be available in 6.2.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Xisco Faulí 2019-08-13 21:01:59 UTC
Hello Oliver Brinzing,
Could you please try again with a build containing the latest commit?
Closing as RESOLVED FIXED
Comment 25 Oliver Brinzing 2019-08-14 06:29:22 UTC
with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 9c92c5e2a4bf15d673b5a8a2589b3109cb0603f7
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

kleopatra will open.
Comment 26 Luc Lalonde 2019-08-28 19:19:37 UTC
Works for me too in nightly:

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 0fb2927a8fe06e6c3255544b8e4c4c9c0f5a67d3
CPU threads: 1; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-27_22:13:47
Locale: fr-CA (fr_CA); UI-Language: en-US
Calc: threaded
Comment 27 Xisco Faulí 2019-09-02 07:48:49 UTC
Setting to VERIFIED then.