Bug 116087 - [osx] cmd+` switches to formula view instead to the next document
Summary: [osx] cmd+` switches to formula view instead to the next document
Status: RESOLVED DUPLICATE of bug 114858
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-28 13:21 UTC by Wojtek
Modified: 2018-03-01 14:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wojtek 2018-02-28 13:21:28 UTC
Description:
cmd+` is default macOS/osx shortcut to switch to new document. After upgrading LibreOffice to version 6, calc stopped switching to the next document and now switches to formula view.

Steps to Reproduce:
1. Open two documents
2. use cmd + ` shortcut


Actual Results:  
Formula view is enabled

Expected Results:
Calc should switch to the next document.


Reproducible: Always


User Profile Reset: No



Additional Info:
It was working in version 4 and 5 just fine


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Alex Thurgood 2018-03-01 13:49:27 UTC
@Wojtek : please let us know which keyboard and which OSX system and keyboard locale you are using.
Comment 2 Alex Thurgood 2018-03-01 13:56:32 UTC

*** This bug has been marked as a duplicate of bug 114858 ***
Comment 3 V Stuart Foote 2018-03-01 14:08:55 UTC
Until 6.1.0 is released, or a back port of the toggle formula change to Ctrl+` to 6.0, one can use Shift+Cmd+` to cycle the window of the front most application. Direction will be reversed.
Comment 4 Wojtek 2018-03-01 14:16:02 UTC
(In reply to Alex Thurgood from comment #1)
> @Wojtek : please let us know which keyboard and which OSX system and
> keyboard locale you are using.

Keyboard (hw): British layout (backtick/tilde between left SHIFT and "z", above ctrl/alt).
Keyboard layout: Polish programmer
OS: macOS 10.13.3 (high sierra) with Spanish locale.