Bug 116098 - Shortcut for recording changes doesn't work
Summary: Shortcut for recording changes doesn't work
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.2.0.1
Keywords: bibisectRequest, regression
: 120536 (view as bug list)
Depends on:
Blocks: Track-Changes Shortcuts-Accelerators GTK3
  Show dependency treegraph
 
Reported: 2018-02-28 22:56 UTC by Zetok
Modified: 2019-04-05 07:55 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zetok 2018-02-28 22:56:05 UTC
Description:
Shortcut (Ctrl + Shift + E) for recording changes (Edit → Track Changes → Record) doesn't work. It worked in LO 5.4.

Steps to Reproduce:
1. Press shortcut (Ctrl + Shift + E)
2. Type something

Actual Results:  
Shortcut doesn't cause LO to start recording changes, but instead LO drops several following keystrokes without changing document in the slightest.

Expected Results:
LO should not drop keystrokes after pressing shortcut, and shortcut should cause LO to start recording changes to the document.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.0.1.1
Build ID: Gentoo official package
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Alex ARNAUD 2018-03-01 10:20:51 UTC
Hello all,

It works correctly on Debian Jessie with LibreOffice 5.2.7 GTK2. Also works with LibreOfficeDev 6.1 GTK2 on Debian Jessie.

I confirm it doesn't work Debian Sid with LibreOffice 6.0.1 and LibreOfficeDev 6.1, both in GTK3.

Best regards.
Comment 2 Caolán McNamara 2018-03-01 15:27:06 UTC
works fine for me with 6.0.1.1 Fedora 27 with gtk3 gtk3-3.22.26 under wayland and under X. What version of gtk3 do the two reporters have, is there a commonality ? 

If you do ctrl+shift+e in gedit does it go into emoji insertion mode ?
Comment 3 Zetok 2018-03-01 17:40:21 UTC
(In reply to Caolán McNamara from comment #2)
> works fine for me with 6.0.1.1 Fedora 27 with gtk3 gtk3-3.22.26 under
> wayland and under X. What version of gtk3 do the two reporters have, is
> there a commonality ? 
> 
> If you do ctrl+shift+e in gedit does it go into emoji insertion mode ?

GTK3 version: 3.22.19

The default ctrl+shift+e shortcut from IBus indeed conflicted with LO shortcut, but I've changed it to ctrl+super+shift+e long time ago.

Using ctrl+shift+e in gedit doesn't open emoji picker, but surprisingly gedit just like LO drops some keystrokes after the shortcut.

After downgrading LO to 5.4.5.1 with GTK2 ctrl+shift+e works again.
Comment 4 Alex ARNAUD 2018-03-01 18:08:01 UTC
(In reply to Caolán McNamara from comment #2)
> works fine for me with 6.0.1.1 Fedora 27 with gtk3 gtk3-3.22.26 under
> wayland and under X. What version of gtk3 do the two reporters have, is
> there a commonality ? 

Here, on Debian Sid, it's GTK 3.22.28.

> If you do ctrl+shift+e in gedit does it go into emoji insertion mode ?

I'm not sure it's a general feature on all distributions, see https://www.omgubuntu.co.uk/2016/12/fedora-25-makes-ridiculously-easy-type-emoji

Best regards/
Comment 5 Alex ARNAUD 2018-03-01 18:09:43 UTC
(In reply to Zetok from comment #3)
> After downgrading LO to 5.4.5.1 with GTK2 ctrl+shift+e works again.

Where do you download the 5.4.5 versions? Can you check on the about dialog if the VCL is GTK2 or GTK3. If I install the 5.4.5 version of LibreOffice from TDF I'm with the GTK2 vcl so the issue doesn't occur.

Best regards.
Comment 6 Alex ARNAUD 2018-03-01 18:12:51 UTC
(In reply to Zetok from comment #3)
> (In reply to Caolán McNamara from comment #2)
> > works fine for me with 6.0.1.1 Fedora 27 with gtk3 gtk3-3.22.26 under
> > wayland and under X. What version of gtk3 do the two reporters have, is
> > there a commonality ? 
> > 
> > If you do ctrl+shift+e in gedit does it go into emoji insertion mode ?
> 
> GTK3 version: 3.22.19

What is your GNU/Linxu distribution ?

Best regards.
Comment 7 Xisco Faulí 2018-03-02 09:11:43 UTC
I can't reproduce it in

Version: 6.1.0.0.alpha0+
Build ID: e2cb154195fdc2ffccdb6f5e87cae8b29640b3eb
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Linux Mint 18.3 Sylvia with GTK 3.18.9-1ubuntu3.3
Comment 8 Zetok 2018-03-02 17:58:50 UTC
(In reply to Alex ARNAUD from comment #5)
> (In reply to Zetok from comment #3)
> > After downgrading LO to 5.4.5.1 with GTK2 ctrl+shift+e works again.
> 
> Where do you download the 5.4.5 versions? Can you check on the about dialog
> if the VCL is GTK2 or GTK3. If I install the 5.4.5 version of LibreOffice
> from TDF I'm with the GTK2 vcl so the issue doesn't occur.
> 
> Best regards.

I've downgraded LO from Gentoo ~testing (6.0.1.1) to stable (5.4.5.1).

The about dialog in LO 5.4.5.1 does show that GTK2 is used.
Comment 9 Xisco Faulí 2018-03-05 16:14:04 UTC
I'm wondering if this issue is Gentoo specific...
Did you have this problem with older versions of LibreOffice?
Comment 10 Alex ARNAUD 2018-03-05 16:18:24 UTC
(In reply to Xisco Faulí from comment #9)
> I'm wondering if this issue is Gentoo specific...
> Did you have this problem with older versions of LibreOffice?

I've the same issue on Debian Sid. See comment #1.

Best regards.
Comment 11 Xisco Faulí 2018-03-05 16:36:34 UTC
Putting back to NEW
Comment 12 Alex ARNAUD 2018-03-05 17:29:56 UTC
(In reply to Caolán McNamara from comment #2)
> works fine for me with 6.0.1.1 Fedora 27 with gtk3 gtk3-3.22.26 under
> wayland and under X. What version of gtk3 do the two reporters have, is
> there a commonality ? 
> 
> If you do ctrl+shift+e in gedit does it go into emoji insertion mode ?

It looks like it's not a LibrOfffice issue indeed, ctrl+shift+e writes "e" with underline on LobreOffice and on Pluma so I assume GTK3 handles this shortcut.

How do you solve the issue on Fedora if this shortcut is already handle?

Best regards.
Comment 13 Caolán McNamara 2018-03-06 13:52:03 UTC
On Fedora 27 ctrl+shift+e works as expected to record macros. This is with gtk3 3.22.26. I don't know if ctrl+shift+e doing something else is happening at the gtk3 level and maybe it varies by version of gtk or if some input method thing is active elsewhere.
Comment 14 Xisco Faulí 2018-03-06 15:57:19 UTC
(In reply to Alex ARNAUD from comment #10)
> (In reply to Xisco Faulí from comment #9)
> > I'm wondering if this issue is Gentoo specific...
> > Did you have this problem with older versions of LibreOffice?
> 
> I've the same issue on Debian Sid. See comment #1.
> 
> Best regards.

Would it be possible to bisect it ?
Comment 15 Alex ARNAUD 2018-03-09 09:38:49 UTC
I've added Rene to CC maybe it could help us more than me on this topic. If it works on Fedora, I assume it should work on Debian and Gentoo.

Best regards.
Comment 16 Alex ARNAUD 2018-03-19 16:11:21 UTC
(In reply to Caolán McNamara from comment #2)
> works fine for me with 6.0.1.1 Fedora 27 with gtk3 gtk3-3.22.26 under
> wayland and under X. What version of gtk3 do the two reporters have, is
> there a commonality ? 

I don't understand why, on Debian testing/sid ctrl+shift+e is handle by GTK3 itself to use the emoji mode.

> If you do ctrl+shift+e in gedit does it go into emoji insertion mode ?

It goes to emoji insertion mode indeed.

Let me know if you need more details. In my understanding (I'm not a GTK developer), it's a keyboard shortcut conflict.

Best regards,
Alex.
Comment 17 Commit Notification 2018-12-12 21:12:50 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/3448584553a214af910ee88cfca6e69bb85bb026%5E%21

Resolves: tdf#116098 avoid ctrl+shift+e as a default shortcut

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2018-12-12 21:12:59 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/9df01c894d73e744a9d55c3db64f052a8f496287%5E%21

Resolves: tdf#116098 avoid ctrl+shift+e as a default shortcut

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Caolán McNamara 2018-12-12 21:14:08 UTC
in the absence of any better idea that commit changes the short-cut to a different unaffected one
Comment 20 Xisco Faulí 2018-12-13 12:29:13 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: e98bcfcc3cdad46620e3d59119b0ac262db88054
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Now it works with Ctrl + shift + C

@Caolán, thanks for fixing this!!
Comment 21 Gabor Kelemen 2019-04-04 07:00:22 UTC
*** Bug 120536 has been marked as a duplicate of this bug. ***
Comment 22 Commit Notification 2019-04-05 07:55:27 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/fb8205ddaa5ef59bf6fe520727b0cb1a5036dc85%5E%21

Related: tdf#116098 avoid ctrl-shift-e shortcut in more places

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.