Download it now!
Bug 116101 - Bullets in bulleted list with proportion >100% appear off
Summary: Bullets in bulleted list with proportion >100% appear off
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All All
: medium normal
Assignee: Szymon Kłos
URL:
Whiteboard: target:6.1.0 target:6.0.3 target:5.4.7
Keywords: bibisected, bisected, regression
: 116267 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-03-01 01:23 UTC by Aron Budea
Modified: 2018-03-13 14:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample ODP (10.62 KB, application/vnd.oasis.opendocument.presentation)
2018-03-01 01:23 UTC, Aron Budea
Details
comparison (77.15 KB, image/png)
2018-03-06 10:54 UTC, Szymon Kłos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-03-01 01:23:33 UTC
Created attachment 140236 [details]
Sample ODP

Open the attached sample presentation, which has a couple of list entries, with line spacing set to 1,15 lines.

=> The bullets and the caret appear lower than the actual text.

Observed with LO 6.0.1.1 & 6.0.0.3 / Windows 7.
No issue with LO 5.4.0.3.
=> regression

Bibisected to the commit referenced below, using repo bibisect-win32-6.1. Adding Cc: to Szymon Kłos, please take a look.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a7e6e4b220089a2d8a58ff10393d598a8b796fa5
author		Szymon Kłos <szymon.klos@collabora.com>	2017-12-21 18:02:13 +0100
committer	Szymon Kłos <szymon.klos@collabora.com>	2018-01-01 21:52:56 +0100

tdf#114628 correct line spacing for impress
Comment 1 Szymon Kłos 2018-03-06 10:54:42 UTC
Created attachment 140376 [details]
comparison

I fixed line spacing for PPTX to match with MSO. In MSO line spacing settings are also applied to the first line. In LO this wasn't applied in the past. That is the difference (but yes, cursor is in the incorrect position).

So what should be done here?
Comment 2 Aron Budea 2018-03-06 13:06:53 UTC
The line spacing looks great, it's the bullet positioning that's off: should be centered in the line.
Comment 3 Commit Notification 2018-03-09 15:46:35 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4b59a110ddd1f02cfa0f677c68c6ef0ee1f3295d

tdf#116101 Correct position for linespacing > 100%

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Szymon Kłos 2018-03-09 15:50:23 UTC
Mistake, I fixed other similar bug, this still occurs...
Comment 5 Commit Notification 2018-03-09 20:22:02 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=63311c2d512f69bff9a2e3c012a4f36a91f23e19

tdf#116101 Correct bullet position for linespacing > 100%

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2018-03-13 13:09:43 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=97dd69362dc4924cf837843bc949ba8ffec0d063&h=libreoffice-6-0

tdf#116101 Correct bullet position for linespacing > 100%

It will be available in 6.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-03-13 13:11:04 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2845f350064f9999a52fa08b752490c3ef7e98c4&h=libreoffice-5-4

tdf#116101 Correct bullet position for linespacing > 100%

It will be available in 5.4.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Buovjaga 2018-03-13 14:52:44 UTC
*** Bug 116267 has been marked as a duplicate of this bug. ***