Bug Hunting Session
Bug 116120 - Print dialog preview does not respect chosen measurement unit
Summary: Print dialog preview does not respect chosen measurement unit
Status: RESOLVED DUPLICATE of bug 40656
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Print-Dialog Measurement-Units
  Show dependency treegraph
 
Reported: 2018-03-01 15:43 UTC by Buovjaga
Modified: 2019-06-27 07:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2018-03-01 15:43:15 UTC
1. Tools - Options - Writer - General: Measurement unit: Inch
2. Ctrl-P

Observe the dimensions around the preview box displayed in millimeters.

3.3 did not yet display the dimensions in the preview.

Version: 6.1.0.0.alpha0+ (x64)
Build ID: e1082e45361a92a31adedcc3ed0a35c704bca543
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-02-15_23:24:06
Locale: fi-FI (fi_FI); Calc: group

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 51291f2352976b2f875197de83486a74795e86a3
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 1st 2018

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 1 raal 2018-03-01 17:18:28 UTC
Confirm,Version: 6.1.0.0.alpha0+
Build ID: 96d551636e9179eb6874a5156b191ef3bff0a10c
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3;
Comment 2 QA Administrators 2019-03-02 03:50:26 UTC Comment hidden (obsolete)
Comment 3 Thomas Lendo 2019-06-08 20:21:56 UTC
Still present in 
Version: 6.3.0.0.beta1
Build ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US

But I don't think this is the right way to think about this because the measurement unit is set in the Writer options. However the print dialog is the same in all applications not only Writer. There should be a LibreOffice options measurement unit setting if the print dialog shall show a specific measuring unit.

Besides that, all measurement unit settings will be ignored in the Writer options. The print dialog always shows millimeters.

Adding needsUXEval to discuss this.
Comment 4 Heiko Tietze 2019-06-12 12:12:03 UTC
Printer settings depend on the locale, in my case German = millimeter. Having one for all measurement setting as of bug 40656 could solve the problem. So make this one a duplicate?

See also bug 78916 about printer settings being different to page settings.
Comment 5 Thomas Lendo 2019-06-12 22:39:40 UTC
I support to make this bug a duplicate of bug 40656 as this cannot be solved otherwise.
Comment 6 Heiko Tietze 2019-06-27 07:11:11 UTC

*** This bug has been marked as a duplicate of bug 40656 ***