Bug 116136 - STATUSBAR: Superfluous tool tips in print preview
Summary: STATUSBAR: Superfluous tool tips in print preview
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Print-Preview
  Show dependency treegraph
 
Reported: 2018-03-02 03:28 UTC by Jim Raykowski
Modified: 2021-03-20 10:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Raykowski 2018-03-02 03:28:47 UTC
To reproduce:
 
1. Menu > File > Print Preview or Shift+Ctrl+O
2. Hover mouse over 2nd box in the status bar

results : shows tooltip "Word and Character Count. Click to open..." 

expected results : no tooltip
Comment 1 Dieter 2018-03-02 08:22:16 UTC
I confirm it with

Version: 6.1.0.0.alpha0+ (x64)
Build ID: d64ce643275e0b2b0dea9e532fc261391dc8793c
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-03-01_03:24:30
Locale: de-DE (de_DE); Calc: CL

Third and fourth box also shows tooltip. Therefore I changed the bug summary.
Comment 2 Xisco Faulí 2018-03-05 16:31:07 UTC
reproduced in

Version: 4.4.0.0.alpha2+
Build ID: 3f94c9e9ddfd807b449f3bb9b232cf2041fa12d2
Locale: ca_ES

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 3 raal 2018-03-09 17:35:58 UTC
This seems to have begun at the below commit.
Adding Cc: to Samuel Mehrbrodt ; Could you possibly take a look at this one?
Thanks
 96fb2d9a30bdf08e122a3db5048bd205c2c23b5b is the first bad commit
commit 96fb2d9a30bdf08e122a3db5048bd205c2c23b5b
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Sun Mar 15 05:30:44 2015 +0800

    source-hash-355770eff40acc07e9cd46fa4dcfb39e6a86166e
    
    commit 355770eff40acc07e9cd46fa4dcfb39e6a86166e
    Author:     Samuel Mehrbrodt <s.mehrbrodt@gmail.com>
    AuthorDate: Tue Nov 11 21:47:01 2014 +0100
    Commit:     Samuel Mehrbrodt <s.mehrbrodt@gmail.com>
    CommitDate: Tue Nov 11 20:53:53 2014 +0000
    
        fdo82708 Add missing tooltips to Writer Statusbar
Comment 4 QA Administrators 2019-03-10 03:21:37 UTC Comment hidden (obsolete)
Comment 5 Dieter 2019-03-10 16:24:26 UTC
I can't reproduce it in 

Version: 6.1.5.2 (x64)
Build-ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group threaded
Comment 6 Jim Raykowski 2019-03-10 16:44:52 UTC
Still can repro using:

Version: 6.3.0.0.alpha0+
Build ID: b440aea0a0b90b7e6700ee7f6f26e0139089c05d
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

and 

Version: 6.3.0.0.alpha0+
Build ID: b440aea0a0b90b7e6700ee7f6f26e0139089c05d
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 Dieter 2019-03-10 17:10:02 UTC
I also can't reproduce with

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 91cdf22b88a4f7bec243c8fb187627e766d3294c
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-08_00:38:10
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded
Comment 8 Jim Raykowski 2019-03-10 23:44:55 UTC
(In reply to Dieter Praas from comment #7)
> I also can't reproduce with
> 
> Version: 6.3.0.0.alpha0+ (x64)
> Build ID: 91cdf22b88a4f7bec243c8fb187627e766d3294c
> CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
> TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-08_00:38:10
> Locale: en-US (de_DE); UI-Language: en-US
> Calc: threaded

Hi Dieter, 

I checked this on a computer with Windows 10 and still could repro with the following versions

Version: 6.2.0.2 (x64)
Build ID: 2ce5217b30a543f7666022df50f0562f82be0cff
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

and

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 82ed9aa096aea95c2a9fe0ca9c1d27b70dcbc8fa
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-01-24_02:04:07
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

For me, in addition to the 2nd box, the 3rd, and 4th boxes also erroneously show tooltips in print preview.
Comment 9 Jim Raykowski 2019-03-10 23:54:45 UTC
I noticed there is a difference in Locale being used by Dieter and I. Locale: de-DE (de_DE) vs Locale: en-US (en_US). Maybe this explains why I repro and Dieter does not.
Comment 10 Dieter 2021-02-14 17:06:40 UTC
Repro with

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 28555fc345ac2ccdda0e4e0f3c812c646befe68b
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded

Don't know, why I wasn't able to reproduce before (see comment 5 and comment 7)
Comment 11 Jim Raykowski 2021-02-23 03:54:35 UTC
Here is a patch to not show statusbar selection mode control tooltip in print preview. This patch also sets the control image disabled when in print preview.

https://gerrit.libreoffice.org/c/core/+/111294
Comment 12 Commit Notification 2021-03-01 02:57:01 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6c897e5026a6819c2d706ccdc9720fb1b3f8bea2

tdf#116136 don't show statusbar selection mode control tooltip

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Jim Raykowski 2021-03-01 21:17:32 UTC
Here is a patch to not show status bar language selection control tool tip when in print preview:

https://gerrit.libreoffice.org/c/core/+/111671
Comment 14 Commit Notification 2021-03-02 21:52:26 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/098f4e84f0fd605eff243c0c494c24dbec95374c

tdf#116136 don't show status bar LangSelection control tool tip

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2021-03-04 00:22:05 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/75175049972239cfceab15c7b756fe0a2c4059be

tdf#116136 don't show status bar word count control tool tip

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2021-03-07 20:12:46 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5d71f2d2168de045ab8d1e0fa80a7580b4facafc

tdf#116136 don't show statusbar template control tooltip

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Jim Raykowski 2021-03-08 05:36:05 UTC
I think these are all taken care of now. Please let me know if there are other concerns here.
Comment 18 Dieter 2021-03-20 10:16:06 UTC
Verified with

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 21c602913d98ef46b49fc9b6f9071db92a1597c6
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Jim, thanks for fixing it!