Bug Hunting Session
Bug 116159 - Can only select another language if you add a word that has to be corrected by the English spell checking ( steps in comment 7)
Summary: Can only select another language if you add a word that has to be corrected b...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Spell-Checking
  Show dependency treegraph
 
Reported: 2018-03-03 14:18 UTC by Johannes Kingma
Modified: 2019-05-15 21:33 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (8.21 KB, application/vnd.oasis.opendocument.text)
2018-03-23 15:59 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Kingma 2018-03-03 14:18:44 UTC
Description:
Selecting language not working

Steps to Reproduce:
1.Select Tools > Spellings and Grammer
2.From Text langauge select German (Switzerland)


Actual Results:  
Language stays "none"

Expected Results:
Language change to "German (Switzerland)"


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Thomas Lendo 2018-03-04 11:48:47 UTC
Have you installed the language pack for German-Switzerland? I don't know Fedora, but on Debian based distros you can search for language packs and install it afterwards.
Comment 2 Dieter Praas 2018-03-04 17:14:11 UTC
(In reply to Thomas Lendo from comment #1)
> Have you installed the language pack for German-Switzerland?

=> SET to NEEDINFO. Please change it back to UNCONFIRMED, when you've answered the question.
Comment 3 Johannes Kingma 2018-03-07 17:26:25 UTC
I have not installed a language pack, no. But the option is there anyway. That is a bit confusing for the end-user. Selecting a spelling for a langauge that is not installed should prompt the user to install the package.

But that is a different problem and should be solved in another ticket.
Comment 4 Dieter Praas 2018-03-07 19:10:36 UTC
(In reply to Johannes Kingma from comment #3)
> I have not installed a language pack, no.

So do you like to try it with the language pack or shall we close this bug?


> That is a bit confusing for the end-user. Selecting a spelling for a
> langauge that is not installed should prompt the user to install the package.
> 
> But that is a different problem and should be solved in another ticket.

I agree.
Comment 5 Thomas Lendo 2018-03-07 23:21:42 UTC
(In reply to Johannes Kingma from comment #3)
> I have not installed a language pack, no. But the option is there anyway.
> That is a bit confusing for the end-user. Selecting a spelling for a
> langauge that is not installed should prompt the user to install the package.
The visual difference is a symbol on the left of the spelling language name. If there is no symbol, no language pack or spell checking extension is installed for this language.

Prompting the user to install something is not so easy from design perspective. Most people can't install it only because of a short info message dialog. Many ways how LibO is installed (Win-Installer, extracted Package, with Package system like on Linux distributions, portable Version ...) result in many ways how it must be handled.
Comment 6 Buovjaga 2018-03-10 18:35:13 UTC
This is the dictionary package name: hunspell-de
Comment 7 Telesto 2018-03-23 15:59:31 UTC
Created attachment 140829 [details]
Example file

I have noticed something similar

1. Local settings USA (Tools -> Options -> Language settings -> Languages
2. Open the attached file
3. Check spelling (F7) -> Spell checking complete.
4. Press OK 
5. Try to select a different language (Italian/dutch) from the drop down box (can't be done). 

6. Reload the document -> file reload
7. Type after book 'argh'
8. Press Check spelling or F7
9. Select a different language -> working
Comment 8 Dieter Praas 2018-03-24 09:21:29 UTC
I can confirm the observed behaviour (comment 7). You can only select another language if you add a word that has to be corrected by the English spell checking

Version: 5.4.6.2 (x64)
Build ID: 4014ce260a04f1026ba855d3b8d91541c224eab8
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: en-US (de_DE); Calc: group

I think this is a bug. Johannes, do you think it is the same problem?
Comment 9 Xisco Faulí 2018-05-03 09:00:11 UTC
Moving to NEW as per comment 8
Comment 10 Johannes Kingma 2018-05-05 07:54:01 UTC
(In reply to Dieter Praas from comment #8)
> I can confirm the observed behaviour (comment 7). You can only select
> another language if you add a word that has to be corrected by the English
> spell checking
> 
> Version: 5.4.6.2 (x64)
> Build ID: 4014ce260a04f1026ba855d3b8d91541c224eab8
> CPU threads: 4; OS: Windows 6.19; UI render: default; 
> Locale: en-US (de_DE); Calc: group
> 
> I think this is a bug. Johannes, do you think it is the same problem?

THis is the same problem, for a different language, yes
Comment 11 QA Administrators 2019-05-06 02:45:50 UTC Comment hidden (obsolete)
Comment 12 Thomas Lendo 2019-05-15 21:33:48 UTC
I can't reproduce it anymore.

Version: 6.3.0.0.alpha0+
Build ID: 98630a0bd49bd80652145a21e4e0d0ded792b36b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-04_04:44:35
Locale: en-US (de_DE.UTF-8); UI-Language: en-US
Calc: threaded

If you still see the problem (described in comment 7), please comment and reopen as NEW.