Bug 116195 - "Designing with LibreOffice"'s front cover images are not rendered in LibreOffice 6.0.2
Summary: "Designing with LibreOffice"'s front cover images are not rendered in LibreOf...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: x86-64 (AMD64) All
: high major
Assignee: Patrick Jaap
URL:
Whiteboard: target:6.1.0 target:6.0.6
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Templates
  Show dependency treegraph
 
Reported: 2018-03-05 09:11 UTC by Iru Cai
Modified: 2018-06-01 03:23 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
template (1.29 MB, application/vnd.oasis.opendocument.text-template)
2018-03-06 15:55 UTC, Xisco Faulí
Details
The result after meddling with the front-cover (1.26 MB, application/vnd.oasis.opendocument.text)
2018-03-11 11:51 UTC, V字龍(Vdragon)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Iru Cai 2018-03-05 09:11:25 UTC
Description:
I have a template file designing-with-libreoffice.ott from the book Designing with LibreOffice (download link: http://designingwithlibreoffice.com/wp-content/uploads/2016/03/DWL-odt-files.zip). When I open this file with LibreOffice-fresh 6.0.2, I only see a blank document, and I can view this template in LibreOffice-still 5.4.5.

Steps to Reproduce:
1. open designing-with-libreoffice.ott with LibreOffice Writer


Actual Results:  
I only see a blank document.

Expected Results:
I should see a document with contents.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Dieter Praas 2018-03-05 10:22:48 UTC
I confirm it with

Version: 6.1.0.0.alpha0+ (x64)
Build ID: d64ce643275e0b2b0dea9e532fc261391dc8793c
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-03-01_03:24:30
Locale: de-DE (de_DE); Calc: CL

All styles are there, but the content of the document is missing


Content is shown in

Version: 5.4.6.1 (x64)
Build-ID: 7d6c666f03cf1f0a0c2c51a17c0f67a8d5a8012b
CPU-Threads: 4; BS: Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 2 Xisco Faulí 2018-03-06 15:54:59 UTC
Regression introduced by:

author	Patrick Jaap <patrick.jaap@tu-dresden.de>	2017-11-29 12:41:33 +0100
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2017-12-11 15:39:10 +0100
commit	8d62b79f168180c6992eb483ec864d473050635f (patch)
tree	41fef4b75064d0c1d6e64809b8ea3b55c2959f7d
parent	4b941b7b7fd79415935c8f2d3ce900eb64a40f66 (diff)
tdf#112443 disable off-page content positioning
Disable the positioning for objects that are completely off-page.
During import, LO writer forces content always back to the page
and causes unwanted content on the page in constrast to MSO.

To achive this the top/left position of the content is compared to the bottom/right border of the clipping region.

A new compatibility flag OFF_PAGE_POSITIONING is introduced for
legacy rendering of legacy documents.

A unit test demonstrates the issue.

It resolves tdf#112443.

Bisected with: bibisect-linux64-6.1

Adding Cc: to Patrick Jaap
Comment 3 Xisco Faulí 2018-03-06 15:55:37 UTC
Created attachment 140393 [details]
template
Comment 4 Patrick Jaap 2018-03-07 18:13:35 UTC
Hi! Thanks for reporting the bug. I'll take a look into the issue.
Comment 5 Patrick Jaap 2018-03-08 12:09:18 UTC
The issue looks a little weird. Let's consider front-cover.odt and back-cover.odt from the zip file. 

front-cover.odt: nothing visible in LO 6
back-cover.odt: everything visible in LO 6 

Yes, my patch disables rendering of off-page images and, unfortunately, the image on the front cover is off-page. So it was more or less an unwanted behavior of LO 5 to show the image. Problem seems to be caused by the "from-left" and "from-top" alignment of the image. The image on the back-cover is positioned on the page, so everything is fine.

You can (if available) look at the situation in Microsoft Office. There, back-cover is shown but front-cover not. So just like LO 6 does now.

You can still access the images by hitting F5 (opening the navigator) and selecting it under "images" -> edit. There you place it e.g. 0cm from the left/top of the page. So maybe updating the files?

Maybe I got something wrong, so feedback would be nice :)
Comment 6 V字龍(Vdragon) 2018-03-11 11:49:27 UTC
(In reply to Patrick Jaap from comment #5)
> You can still access the images by hitting F5 (opening the navigator) and
> selecting it under "images" -> edit. There you place it e.g. 0cm from the
> left/top of the page. So maybe updating the files?
I managed to "fix" the issue with a weird way, please check it out:
https://www.youtube.com/watch?v=oSmMBQydoGI

Also can you make it clear how to "There you place it e.g. 0cm from the left/top of the page."?
Comment 7 V字龍(Vdragon) 2018-03-11 11:51:08 UTC
Created attachment 140562 [details]
The result after meddling with the front-cover
Comment 8 V字龍(Vdragon) 2018-03-11 11:58:10 UTC
(In reply to V字龍(Vdragon) from comment #6)
> I managed to "fix" the issue with a weird way, please check it out:
> https://www.youtube.com/watch?v=oSmMBQydoGI

In fact the 0.00 doesn't even to be touched, simple open the properties window and click "Confirm" to close it will make the image re-appear.
Comment 9 Patrick Jaap 2018-04-10 13:35:33 UTC
Hi!

Indeed, there was a little bug causing the problem. Fix is in review, stay updated :)
Comment 10 Commit Notification 2018-04-18 07:44:16 UTC
Patrick Jaap committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fe3d5766fa3c42f6cf8d1ea47af820e0b1c1cf48

tdf#116195 swap a compatibility value

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2018-05-29 09:28:44 UTC
A polite ping to Patrick Jaap:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 12 Xisco Faulí 2018-05-31 10:24:09 UTC
Verified in

Version: 6.1.0.0.beta1+
Build ID: 2a0d8106a558845357d39648656e08ec6f091cf8
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

@Patrick Jaap, Thanks for fixing this!!

Cherry-picked to 6-0: https://gerrit.libreoffice.org/#/c/55120/