Bug 116196 - Impress presentation renders a white rectangle over content (OpenGL)
Summary: Impress presentation renders a white rectangle over content (OpenGL)
Status: RESOLVED DUPLICATE of bug 115142
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2018-03-05 09:26 UTC by Johannes Kingma
Modified: 2018-03-07 12:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
odp file and screenshot (95.19 KB, application/x-7z-compressed)
2018-03-05 09:26 UTC, Johannes Kingma
Details
Screenshot (94.52 KB, image/png)
2018-03-06 21:59 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Kingma 2018-03-05 09:26:41 UTC
Created attachment 140343 [details]
odp file and screenshot

With the document attached a white rechtangle is projected over the presentation, when in presentation mode.

Removing the text box with the date in it removes this.
Comment 1 Telesto 2018-03-05 16:00:40 UTC
No repro with:
Version: 6.1.0.0.alpha0+
Build ID: e108a31a8fee09c2fa4031e45e45ed73bbdb7c6f
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-03_23:36:02
Locale: nl-NL (nl_NL); Calc: CL
Comment 2 Timur 2018-03-05 16:06:23 UTC
No repro. Please check your report. Please also test with master http://dev-builds.libreoffice.org/daily/master/
Comment 3 Aron Budea 2018-03-06 02:52:05 UTC
Confirmed in LO 5.4.5.1 & 6.0.2.1 / Windows 7, only with OpenGL enabled.
No issue in LO 5.4.0.3.
=> regression
Comment 4 Xisco Faulí 2018-03-06 14:36:55 UTC
@Aron, Could you bisect it when you have some time ?
Comment 5 Aron Budea 2018-03-06 21:57:50 UTC
Bibisected using repo bibisect-win32-6.0 to the commit referenced below. Adding Cc: to Michael Stahl, please take a look sometimes. The commit doesn't seem OpenGL-specific, so it's possible the commit just caused an unrelated issue to appear.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=99e373cd4c78084ded349f3e3de7b0504af2dd90
author		Michael Stahl <mstahl@redhat.com>	2017-11-10 23:28:19 +0100
committer	Michael Stahl <mstahl@redhat.com>	2017-11-10 23:53:15 +0100

slideshow: clip shapes in secondary screen window
Comment 6 Aron Budea 2018-03-06 21:59:02 UTC
Created attachment 140405 [details]
Screenshot

For me lines appear rather than a rectangle.
Comment 7 Michael Stahl (CIB) 2018-03-07 12:15:36 UTC
i can't reproduce the bug but i've reverted the commit in comment #5
because it was wrong so let's call it a duplicate.

*** This bug has been marked as a duplicate of bug 115142 ***