Download it now!
Bug 116205 - SVG import does not correctly manage clipping
Summary: SVG import does not correctly manage clipping
Status: RESOLVED DUPLICATE of bug 97657
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2018-03-05 14:17 UTC by sergio.callegari
Modified: 2018-03-05 19:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
test case (8.83 KB, image/svg+xml-compressed)
2018-03-05 14:18 UTC, sergio.callegari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2018-03-05 14:17:35 UTC
Description:
When inserting SVG, elements that should be trimmed to some contour, end up not trimmed in LibO.

Steps to Reproduce:
1. Insert an SVG file which uses some trimming/clipping feature


Actual Results:  
See that the element(s) that should be trimmed to some contour end up protruding out of it

Expected Results:
The image should appear as in other SVG viewers (e.g., inkscape)


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: PresentationDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 sergio.callegari 2018-03-05 14:18:12 UTC
Created attachment 140356 [details]
test case
Comment 2 V Stuart Foote 2018-03-05 19:18:32 UTC
Believe this is dupe of bug 97657 but also 90168

*** This bug has been marked as a duplicate of bug 97657 ***