Download it now!
Bug 116217 - Export as EPUB does not include pictures
Summary: Export as EPUB does not include pictures
Status: RESOLVED DUPLICATE of bug 115722
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: EPUB-Export
  Show dependency treegraph
 
Reported: 2018-03-05 21:28 UTC by Alan
Modified: 2018-03-06 02:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Document used to create examples (26.72 KB, application/vnd.oasis.opendocument.text)
2018-03-05 21:30 UTC, Alan
Details
Epub book created without pictures (2.47 KB, application/epub+zip)
2018-03-05 21:30 UTC, Alan
Details
Epub book with picture (expected result) (20.81 KB, application/epub+zip)
2018-03-05 21:31 UTC, Alan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alan 2018-03-05 21:28:37 UTC
Description:
When creating an epub from a Writer document no pictures in the document are included in the epub file.

Steps to Reproduce:
1.Create a document with pictures
2.Do 'File' --> 'Export as' --> 'Export as EPUB'
3.Newly created ebook does not have any pictures

Actual Results:  
There are no pictures included in the ebook (see epub-pic-test.epub)

Expected Results:
Would expect the ebook to look like the writer document (see epub-pic-expected.epub)


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Document used to create the ebooks is included.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Alan 2018-03-05 21:30:03 UTC
Created attachment 140366 [details]
Document used to create examples
Comment 2 Alan 2018-03-05 21:30:42 UTC
Created attachment 140367 [details]
Epub book created without pictures
Comment 3 Alan 2018-03-05 21:31:41 UTC
Created attachment 140368 [details]
Epub book with picture (expected result)
Comment 4 Aron Budea 2018-03-06 02:26:32 UTC
This should be fixed in master, and can be tested in a master daily build from [1]. For details please see bug 115722.

[1] https://dev-builds.libreoffice.org/daily/master/

*** This bug has been marked as a duplicate of bug 115722 ***