Bug 116230 - Excel has problem opening file after Share Workbook has been selected in Calc
Summary: Excel has problem opening file after Share Workbook has been selected in Calc
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: XLSX-Corrupted
  Show dependency treegraph
 
Reported: 2018-03-06 11:13 UTC by zak
Modified: 2019-11-20 03:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
File attached with problem (115.59 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-03-06 11:13 UTC, zak
Details
ODF file before problem started (107.83 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-04-05 14:33 UTC, zak
Details
Xls file before problem (176.49 KB, application/vnd.ms-excel.sheet.macroEnabled.12)
2018-04-05 14:35 UTC, zak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zak 2018-03-06 11:13:08 UTC
Created attachment 140377 [details]
File attached with problem

Workbook used to be edited by Excel2013/2016 and Calc, but once I selected Review>Share Workbook and saved Excel can't change the docuemnt anymore, comes up with an error: 
"Excel Found unreadable content in some parts of the Shared Workbook. Excel Can attempt to recover the content of this workbook by savingit with a different name or opening the workbook read-only in it's current state"

The recovery does not fix the problem. I've tried in Open XML, xlsx nd odf format
Comment 1 Buovjaga 2018-03-12 13:27:55 UTC
I confirm with MS Excel 2013, but do you have a version of the file from before the problem started? Preferably you would have an ODS file that we could then use with scientifically reproducible steps to bring about the problem.
Comment 2 zak 2018-04-05 14:33:13 UTC
Created attachment 141133 [details]
ODF file before problem started
Comment 3 zak 2018-04-05 14:35:21 UTC
Created attachment 141134 [details]
Xls file before problem

Took a while to get files from backup, but have attached both ODF and XLS file from before the error
Comment 4 Buovjaga 2018-04-12 13:25:01 UTC
I cannot arrive at the same problematic situation when starting with the .ODS.

I saved the ODS as XLSM from Calc.
I saved the XLSM as XLSX from Excel 2013.

I don't get the same problem.

The XLSX you attached clearly has huge issues as it even caused Excel to crash on me.

Are you able to recreate the problematic steps?

LibreOffice Version: 6.1.0.0.alpha0+
Build ID: 84e2614a75a615d6c8584b13a69b3368d2a12a3d
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-04-12_09:11:38
Locale: fi-FI (fi_FI); Calc: group
Comment 5 Xisco Faulí 2018-05-31 11:50:10 UTC
> Are you able to recreate the problematic steps?

Dear Zak,
Could you please answer the question above in order to help to reproduce the issue?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the question has been answered
Comment 6 zak 2018-11-19 09:37:14 UTC
I'since loaded a new version 6.1.3 on the PC, and no longer have the issue. Please let me know if you want me to load the old version and try and recreate the issue?
Comment 7 Xisco Faulí 2018-11-19 09:41:21 UTC
(In reply to zak from comment #6)
> I'since loaded a new version 6.1.3 on the PC, and no longer have the issue.
> Please let me know if you want me to load the old version and try and
> recreate the issue?

Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.
Comment 8 Aron Budea 2018-11-19 10:46:17 UTC
I can still reproduce the issue with LO 6.2beta1, by sharing attachment 141134 [details] in Calc, which also saves it. Opening it in Excel 2013 results in the error mentioned in the description.
Comment 9 QA Administrators 2019-11-20 03:50:47 UTC
Dear zak,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug