Download it now!
Bug 116237 - When selecting certain Border formats and a Border Style from the toolbar button, the style is not correct.
Summary: When selecting certain Border formats and a Border Style from the toolbar but...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Border
  Show dependency treegraph
 
Reported: 2018-03-06 14:33 UTC by Aprax
Modified: 2019-03-21 21:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
example of ods created with V5 which is OK (21.37 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-03-06 14:33 UTC, Aprax
Details
example of ods created with V6 (20.36 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-03-06 14:34 UTC, Aprax
Details
a comprehensive demonstration of the bug in V 6.0.2.1 (12.64 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-03-12 11:54 UTC, Aprax
Details
shows bug as both New and Fixed----? (68 bytes, text/plain)
2018-03-20 13:02 UTC, Aprax
Details
Borders now OK (32.95 KB, image/png)
2019-03-21 14:43 UTC, Aprax
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aprax 2018-03-06 14:33:06 UTC
Created attachment 140388 [details]
example of ods created with V5 which is OK

Such a simple thing to break. 
When selecting certain Border formats and a Border Style, the style is not correct. See the attachments for examples that were 
- correct if the ods was created by calc V5 but
- wrong if the ods was created by or copied from a V5 into calc V6

There are two ods attachments, 
- one created by V5 which still works correctly when accessed by V6,
- the other created with V6 and which has a bug (and other sheets for other bugs)

Try changing the border and border style to all 4 sides of a cell or range with thick lines. OK in V5, wrong in V6.

Try changing the border and border style to all 4 sides of a cell or range with double lines. OK in both V5 and V6. (skinny lines are OK too)

I didn’t reset my Profile

OpenGL was unticked
Comment 1 Aprax 2018-03-06 14:34:22 UTC
Created attachment 140389 [details]
example of ods created with V6
Comment 2 Buovjaga 2018-03-11 11:49:20 UTC
This smells like bug 103924, but things are not clear.

Just to be clear: do you reproduce the bug *from scratch* in version 6? If yes, please give exact steps on selecting the border style.

I am asking, because if I open Format cell in 6, the Style dropdown does not show anything. That is why I suspect the legacy of bug 103924 being involved.
Comment 3 Aprax 2018-03-12 11:52:39 UTC
If you know how to use the icons on the Menu bar then do this
1) left click on the drop down arrow for Borders
2) options are displayed in a 3 x 4 matrix. click on the option to surround a cell or range of cells (hint: it's on the second row in the fourth column (right)
3) left click on the drop down arrow for Border style. drag the slider down until you see the third from the bottom wide bar and left click on it.
That's all that I do, LO Calc does the rest by putting a thick border horizontally both top and bottom and incorrectly putting a skinny border line vertically both on the left and right.

To help you visualize this I prepared and attached an ods file named Borders.
It shows the borders for all 14 options

I have only Calc V 6.0.1.2 installed.
If I create a new ods, the borders are drawn incorrectly
If I open an old ods created by V5, the borders are drawn correctly

This makes me think that, when a new ods is created, Border definitions are retrieved and stored within the ods rather than being retrieved from Calc each time the ods is opened.
This raises the issue of how a correction can be designed and applied to:
1) correct the definitions in Calc itself and
2) how to transfer those correct definitions to each ods with the incorrect definitions.
We’d need to know what an incorrect definition looks like, test for it and if found, replace it with a correct definition.

On a side note: There are only 5 Border style variations that make sense to have, but 2 need fixing. The other options look just like an other option and are therefore redundant and should be removed. I documented this in the ods which I’ve attached.
This makes me think that at one time all 14 looked different but over time were converted to what we see now.
Comment 4 Aprax 2018-03-12 11:54:35 UTC
Created attachment 140577 [details]
a comprehensive demonstration of the bug in V 6.0.2.1
Comment 5 Buovjaga 2018-03-12 12:30:30 UTC
(In reply to Aprax from comment #3)
> If you know how to use the icons on the Menu bar then do this
> 1) left click on the drop down arrow for Borders
> 2) options are displayed in a 3 x 4 matrix. click on the option to surround
> a cell or range of cells (hint: it's on the second row in the fourth column
> (right)
> 3) left click on the drop down arrow for Border style. drag the slider down
> until you see the third from the bottom wide bar and left click on it.
> That's all that I do, LO Calc does the rest by putting a thick border
> horizontally both top and bottom and incorrectly putting a skinny border
> line vertically both on the left and right.

Right, there is a discrepancy between the Format cells dialog and the toolbar dropdown button. The toolbar button contains more styles than the dialog. I was working in the dialog this whole time.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: de53d4690d25b9f1bbc0def6c66ce5b45b2fdc96
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 12th 2018
Comment 6 Aprax 2018-03-14 17:57:41 UTC
Why would there be two very different ways to select a Border and Border width?
I thank you for pointing me to the Format way, it's basically much easier to understand and use. It's not completely intuitive when designing a border with less than 4 sides but I did find the double left click could remove a single side.
However the check box for "Remove border" acts weirdly. It's greyed out initially,it stays greyed if I single click to select a single side, but if I click again on the border, the border disappears and the check box is active which seems pointless since the border is gone. However, once active I can click on other sides and they disappear so it's just a learning curve by trial and error although really, the check box should always be active or someone needs to explain why it isn't..
Comment 7 Aprax 2018-03-19 12:01:48 UTC
to 'fix' THIS bug change both of the Menu bar icons to simply open the "Format Cells..." at the Border tab.
You could leave or remove the spurious code that existed under the icons.
This way, anyone (like me) would be directed to the code that works properly.
Comment 8 Aprax 2018-03-19 12:07:13 UTC Comment hidden (off-topic)
Comment 9 Buovjaga 2018-03-19 12:20:42 UTC Comment hidden (off-topic)
Comment 10 Aprax 2018-03-20 10:53:54 UTC Comment hidden (off-topic)
Comment 11 Buovjaga 2018-03-20 11:23:11 UTC Comment hidden (off-topic)
Comment 12 Aprax 2018-03-20 13:01:10 UTC Comment hidden (off-topic)
Comment 13 Aprax 2018-03-20 13:02:40 UTC Comment hidden (off-topic)
Comment 14 QA Administrators 2019-03-21 03:49:58 UTC Comment hidden (obsolete)
Comment 15 Aprax 2019-03-21 14:43:27 UTC
Created attachment 150148 [details]
Borders now OK

The Borders are drawn as expected now in version 6.2.0.3 x64, thank you!
Comment 16 Buovjaga 2019-03-21 21:08:00 UTC
Great news, let's close.